2

This question already has an answer here:

I have been trying for a while to install vlc 3.0 on ubuntu 17.10, with no luck. I even installed the snap version but it doesn't seem to play videos outside of the home folder, so I can't view videos on my other partitions.

Thing is, when I try to install vlc 3.0 from the stable PPA, I get vlc 2.2.6 instead. After adding the PPA and run sudo apt-get update, I get the following error

 E: The repository 'http://ppa.launchpad.net/videolan/stable-daily/ubuntu artful Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

I have tried removing the PPA and adding it back but it still says the same thing. Am I missing something

EDIT: I have tried the solution from this link but I still get the release file not found error

marked as duplicate by N0rbert, Eric Carvalho, waltinator, David Foerster, user68186 Apr 17 '18 at 15:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • As per edit the dupe doesn't work. Snap is the only way to go. I can play files from outside the home folder just fine with the snap version. What's the error you're getting? – Fabby Apr 15 '18 at 15:54
  • Could you please add a little more detail? What exactly did you do, what did you expect to happen and what happened instead? Did you encounter any warning or error messages? Please reproduce them in their entirety in your question. You can select, copy and paste terminal content and most dialogue messages in Ubuntu. Please edit your post to add information instead of posting a comment. (see How do I ask a good question?) – David Foerster Apr 16 '18 at 11:40
0

Remove VLC PPAs and revert it to the version from repository:

sudo apt-get install ppa-purge

sudo ppa-purge ppa:videolan/stable-daily
sudo ppa-purge ppa:videolan/master-daily

These actions are needed because of the fact that PPAs do not have packages for Artful anymore.

Then remove vlc snap

sudo snap remove vlc

And install it again with --classic option:

sudo snap install --classic vlc
  • I tried installing snap with the --classic version but it still doesn't play videos outside the home directory – Gozie Apr 14 '18 at 14:16
  • I'm not sure, but it seems that the best solution would be to upgrade to Bionic Beaver 18.04 LTS as it has VLC 3.0.1 in the repository. – N0rbert Apr 14 '18 at 14:22
  • I thought that version wasn't out until 26th. That was when I planned on upgrading. – Gozie Apr 14 '18 at 14:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.