3

I'm trying to dual boot Ubuntu on my new Lenovo Yoga 720. I know that the OEM Windows installation was in RAID mode. It also had a bunch of bloatware. So I changed the storage controller to AHCI mode in the BIOS and clean installed Windows 10.

Now, whenever I try to install Ubuntu, the installer doesn't recognize the SSD. Initially, the installer wouldn't even start and I'd get a black screen. It turned out I needed a BIOS update. After updating the BIOS I get the installer screen but it always gets stuck on the searching for partitions screen or just before it. I've tried Ubuntu 16.04, 17.10, and 18.04, but no luck. I thought this might be an issue with a my USB stick, so I tried different ones from different brands but to no avail. I've tried different settings in the BIOS, but it didn't help either. Thinking that it might be a problem with the way my Windows installation set up the SSD partitions, I even tried zapping the Windows installation and install Ubuntu on a clean SSD but that didn't work either. I even tried installing Windows in both UEFI and Legacy modes but it made no difference.

I can boot Ubuntu from the USB stick in live mode. The Ubuntu file manager can see the SSD and its partitions. I can even browse the Windows files from there. However, when I try opening GParted it never opens. I get an indefinitely spinning cursor. I tried running the sudo parted -l and sudo gdisk -l /dev/sda/ commands but terminal hangs up. Worse yet, new instances of the terminal don't open after it failing on the above mentioned commands.

I've tried browsing through various forums and trying different things but have had no success. I'm at my wits' end. Any help would be appreciated.

The laptop's specs are as follows. Core i7 7700HQ 16 GB DDR4 RAM 512 GB NVMe SSD

BIOS version 2.03

Thank you very much.

1 Answer 1

1

Well, so not long after posting this question, I tried disabling "Intel Platform Trust Technology" option in the BIOS, and voilà, I was able to install Ubuntu 18.04.

That seems to have solved the problem. Only problem now is to enable switchable graphics.

Thank you for reading. I hope this can help someone else facing a similar issue.

Cheers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.