The max screen saver delay on Ubuntu 17.10 seems to be 15 minutes. Is there a way to increase to say 45 minutes?

1 Answer 1


You should be able to do this using the following command:

gsettings set org.gnome.desktop.session idle-delay 2700

Alternatively you can install dconf-editor and use it to browse to this value and set it, if you prefer a GUI approach.

After settings this, the gnome settings dialog will list a value of "never" for this key. I haven't tried waiting for 45 minutes to see if it indeed does what one would expect.

Side note

How did I find out? I dumped my current gsettings using the following command:

for s in $(gsettings list-schemas); do for k in $(gsettings list-keys $s); do echo -n "$s/$k: "; gsettings get $s $k; done; done >gsettings.1

Then changed the setting using the gnome settings dialog. Then ran the command again, but replace gsettings.1 with gsettings.2, to dump again the settings into another file.

Afterwards I could use diff like this to see which key was changed:

diff gsettings.1 gsettings.2
< org.gnome.desktop.session/idle-delay: uint32 900
> org.gnome.desktop.session/idle-delay: uint32 600

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.