2

I used to have a working install of vlc on my system.

NAME="Ubuntu"
VERSION="16.04.4 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04.4 LTS"

After a long bout of not being connected to the interwebs, my system fell out of date, when I reconnected to the internet, and tried to update and upgrade, it failed and failed and failed. Finally found that VLC was to blame, or gradio?, but got rid of them, and their sources, and finally got it updated and upgraded using

apt-get update --fix-missing && apt-get dist-upgrade --fix-missing -f -y && reboot

^really just truncated example, after trying --fix-missing it recommended I add -f.

Figured now I would try to get the video player installed again. Yet I run into this error:

Setting up libxcb-composite0:amd64 (1.11.1-1ubuntu1) ...
Setting up vlc (2.2.2-5ubuntu0.16.04.4) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Processing triggers for vlc-nox (2.2.2-5ubuntu0.16.04.4) ...
    /usr/lib/vlc/vlc-cache-gen: error while loading shared libraries: libvlccore.so.8: cannot open shared object file: No such file or directory
WARNING: Regenerating VLC plugin cache failed.
Please run 'vlc-cache-gen -f /usr/lib/vlc/plugins' manually.

root@wrench:/home/wrench# vlc-cache-gen -f /usr/lib/vlc/plugins

    vlc-cache-gen: command not found

root@wrench:/home/wrench# cd / && ./usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins

    ./usr/lib/vlc/vlc-cache-gen: error while loading shared libraries: libvlccore.so.8: cannot open shared object file: No such file or directory

root@wrench:/# locate libvlccore.so

    /usr/lib/x86_64-linux-gnu/libvlccore.so.9
    /usr/lib/x86_64-linux-gnu/libvlccore.so.9.0.0

So synopsis, what the heck do I do now? Is there a way to downgrade libvlccore.so back to 8? Maybe not due to security implications? Maybe I'm doing something stupid like installing the wrong architecture? I know I messed with the arch to get an package installed when I first set up the box, but was careful to check (I thought) that everything was changed back after the install. Please help, the family is bored!

Maybe someone knows where to find libvlccore.so.8?

  • libvlccore.so.8 is used on all Ubuntu-provided versions of VLC in 16.04 - 17.10. libvlccore.so.9 is used in 18.04. Ubuntu does NOT upgrade VLC versions during the life of an LTS (the whole point of LTS is that the versions are stable). Therefore, it seems likely that you installed some non-Ubuntu version of VLC. We don't support those. Uninstall it. – user535733 Apr 14 '18 at 12:29
  • How would I go about finding it, as far as i know, i removed what I had, in an attempt to fix it. apt-get purge vlc and all.. EDIT : trying apt-get autoremove now. – John Ferris Apr 19 '18 at 3:06
  • Remove all vlc source packages, update your sources & install vlc.. You obviously had used a vlc ppa in the past. To use the repo version this should suffice sudo apt purge libvlccore9 vlc-data then sudo apt update then sudo apt install vlc If still issues then run apt-cache policy vlc & post – doug Nov 9 '18 at 1:53
1
cd /usr/lib/x86_64-linux-gnu
sudo ln -s libvlccore.so.9 libvlccore.so.8

This will create a symlink called libvlccore.so.8 to the version you have, libvlccore.so.9, so programs looking for version *8 will call the newer library. This is not generally good practice, since version 9 is different from 8 and may not work. It can serve as a workaround, though.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.