1

I have Xubuntu-Desktop installed over Ubuntu, and Thunar File Manager is installed by default.

However, it does not show up as an application in any of my searches. I can run it by typing thunar in the the terminal.

This is a problem because Docky (my dock application) does not detect Thunar.

Here are some screenshots:

Thunar Does not show up:

Thunar Does not show up

Only the option to 'run thunar' shows up: Only the option to run thunar shows up

Thunar does not show up in applications list: Thunar does not show up in applications list

I know for a fact that thunar is installed: Thunar is installed

I have tried uninstalling and reinstalling thunar. Any ideas on how to fix this?

Edit: I found a solution for anyone that sees this in the future:

sudo cp /usr/share/applications/Thunar.desktop ~/.local/share/applications

Answer is from here: Xfce - Docky & Thunar - Missing icon

  • Some DEsktops call apps by their name (eg. Thunar), others list them in menus by what the do (File Manager). This is just a difference, and not a problem needing fix. If you're not happy with your menu system, use another one – guiverc Apr 14 '18 at 0:09
  • Yeah but both 'Files' and 'File Manager' launch nautilus instead of thunar even though thunar is set as my default. Also other applications like docky don't recognize that thunar exists which means I can't keep it in my dock – user3011052 Apr 14 '18 at 0:15
  • 1
    Please edit, add the answer as second post below removing it from the question and accept the answer that helped you most by clicking the tick left to it. – dessert May 4 '18 at 8:06
0

The File Manager listing in the Appfinder menu is associated to the exo-preferred-applications settings so it opens whatever the default is set to.

Press Alt+F2 and in the run box type in exo-preferred-applications.

enter image description here

Then click on Launch.

Go to the Utilities Tab then in File Manager choose Thunar. Then close the application.

enter image description here

Now, every time you open that File Manager it will launch Thunar.

Hope this helps!

  • Thanks for taking the time to answer, I already found the solution using a different method (I edited my post to include the answer). I don't know if this would have worked but it will hopefully be useful for people who view this thread in the future – user3011052 Apr 14 '18 at 2:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.