1

I've tried to set up the pptp connection in ubuntu with the default settings, the connection works in windows 7 also in windows xp, it even works with ubuntu within same provider's network. I've tried to connect with two different computers on my home network (both pc are able to connect with vpn in windows 7) but with ubuntu i got error vpn connection failed because vpn stopped. I found this VPN connection failed because service stopped unexpectedly but that did not help me. When i tried pc within same provider's network is working with the default settings (so only the gateway, name and password are set), I've also checked router's setup and there is no problem, it is possible that my isp blocks the linux vpn, but not in windows?

  • Is your firewall on ? What is the output of sudo ufw status? – oscar1919 Apr 13 '18 at 13:04
  • I have tried to disable firewall with sudo ufw disable. It didn't help. – nigue Apr 13 '18 at 13:22
0

For setting up a pptp vpn on lubuntu I went through a lot of trouble. The details on how I managed to do so are described in this link.
Maybe it can help you.
In searching for a solution, I read a lot of warnings that pptp is unsafe and should be avoided where possible, so I carefully pass this warning on.

  • Thanks, I will try this, but what bothers me is that on different computer within the same isp network, I didn't have to do anything, just set up pptp vpn connection, connect and it worked with default settings (12.04.5 LTS). Why I have to do this on my homework with two different versions of ubuntu (12.04.5lts, and 16.04.5 lts). Windows 7 works fine. – nigue Apr 13 '18 at 13:39
  • Are there any other suggestions? – nigue Apr 13 '18 at 17:12
  • Did you try reinstalling the packages, as described in the link? I have set up such a connection on Lubuntu 17.10, and Ubuntu 16.04 in a virtual box, using the same steps. After the fifth bullet connecting to the VPN leads to a popup that the vpn connected succesfully (but then I had other problems). No experience with older versions. – oscar1919 Apr 13 '18 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.