5

I have a Surface pro 3 and I tried to dual boot it, but I have done something wrong and now it just boots to UEFI.

I have all my life inside this little SSD and I know I'm sooo stupid because I didn't back it up and now it's encrypted.

I have booted it to Ubuntu using USB flash drive and pressed the TRY UBUNTU so I won't lose my data

So Anybody please could tell me how to decrypt it so I could recover my data back?

I have the encryption key

1

2 Answers 2

5

After booting into the ubuntu the live cd, enable the universe repository

settings > software and update > ubuntu software > tick community maintained software

update the local repo and install some needed packages:

sudo apt update
sudo apt install dislocker libfuse-dev

make two folders, /media/bitlocker and /media/mount:

sudo mkdir /media/bitlocker /media/mount

find the encrypted windows partition:

lsblk

you would see something like

NAME         MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      179:0    0  58.2G  0 disk 
├─sda1   179:1    0   200M  0 part /boot/efi
├─sda2   179:2    0  54.3G  0 part /

per the sizes you can predict your windows partition

decrypt that partition with your bitlocker password:

sudo dislocker -r -V /dev/sdaX -u -- /media/mount

followed by password
OR

sudo dislocker -r -V /dev/sdaX -uPASSWORD -- /media/bitlocker

Replace PASSWORD with your bitlocker password

In case you want to use the recovery password instead, we can decrypt it using that:

sudo dislocker -r -V /dev/sdXY <recov_pass> --  /media/bitlocker
sudo dislocker -r -V /dev/sdaX -p1536987-000000-. . .-000000-000000 -- /media/bitlocker

replace 1536987-000000-. . .-000000-000000 with your recovery password

Now, we finally mount:

sudo -i
cd /media/bitlocker
mount -r -o loop dislocker-file /media/mount

Now you can move to the /media/mount folder and see your decrypted data

For detailed answer look at this answer and that answer

1
  • sudo add-apt-repository universe to add universe from the cmdline.
    – sferencik
    Commented Apr 2, 2022 at 17:19
1

ptetteh227's answer was just the fix I needed. Just an FYI for anyone else.

mount -r -o loop dislocker-file /media/mount

did not work for me.

mount -o ro,loop /media/bitlocker/dislocker-file /media/mount

worked and I was able to access the data off the encrypted volume.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .