2

I've seen this problem reported a few times for example this Ask Ubuntu question: Xrdp login failed but none of the questions had answers which worked for me - so I am raising a new post to try and get help with this. I think the difference between the other questions and mine is that I am on a company network and I am using a company-wide login. So the logon (userid/password) for my Windows desktop is the same as for my Ubuntu desktop.

I am trying to connect to my Ubuntu v16.04 Desktop from a Windows7 desktop using Windows Remote Desktop (RDP) but I get the error,

xrdp_mm_process_login_response:login failed

SesmanXvnc Logon Screen

Error Message

I am able to connect to the Ubuntu desktop from my Windows machine using Putty/openssh and also via a VNCViewer...but I would like to be able to use Windows RDP.

I have installed the xrdp software on Ubuntu but as shown in the screenshot there is an issue authenticating myself via the "SesmanXvnc" login screen.

I assume that my login credentials are picked up from our company network but I don't know how this works exactly in Ubuntu. I use the same credentials with Ubuntu as I use to log into Windows.

2
  • 1
    Possible duplicate of Xrdp login failed – Joseph Sible-Reinstate Monica Apr 13 '18 at 11:23
  • thanks Joseph - I've updated my question to reference this question. I have tried the solution in this question already and it didnt fix my issue - I still get the same error message. – robbie70 Apr 13 '18 at 12:46
0

Based on the screenshots provided, you are using the xrdp version 0.6.x this error can occur when password provided is incorrect.

Just an idea

By default, the xrdp login screen provided in the screenshot will use en-us keyboard layout. Can you ensure that the password provided is correct based on your keyboard layout ? Type your password on the user name text box and check that the keyboard layout is not the problem...

Hope this help Till next time See ya

1
  • Thanks Griffon. I've have already tried this and can confirm that the password prints correctly. I agree with you that it seems there is an issue with the password. We have an MS Windows network into which I authenticate, previously from a Windows7 desktop but now from an Ubuntu desktop. Both logons work fine from the respective desktops but I hit the problem shown above when I try to remote from my Windows 7 destop onto my Ubuntu desktop. I dont know how that authentication mechanism works and so dont know how to investigate/debug the error I am seeing above. Any help would be appreciated. – robbie70 May 21 '18 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.