9

In IntelliJ IDEA 2018.1 on Ubuntu 16.04 with Unity the shortcut Ctrl+Alt+S doesn't work. The key map is set on Default for Gnome. How to resolve this issue?

Output for for d in /org/gnome/settings-daemon/plugins/media-keys/ /org/gnome/desktop/wm/keybindings/ /org/gnome/settings-daemon/plugins/power/; do dconf dump "$d"; done | grep -iFe '<Control><Alt>S' is:

toggle-shaded=['<Control><Alt>s']
4
  • @DavidFoerster I expect to work. When I manually (by mouse open) open File menu there is the legend that shortcut is CTRL-ALT-S.
    – djm.im
    Apr 13, 2018 at 15:42
  • @DavidFoerster Done
    – djm.im
    Apr 13, 2018 at 16:05
  • @DavidFoerster Disable it. Now it works. Please write an answer to the question to mark it as the solution.
    – djm.im
    Apr 13, 2018 at 16:19
  • Possible duplicate of askubuntu.com/questions/412046/… Apr 19, 2018 at 23:38

2 Answers 2

4

It appears that the window manager already captures the key combination Ctrl+Alt+S.

To unbind it or rebind it to a different key combination

  1. open the Control Center,
  2. navigate to Keyboard → Shortcuts,
  3. select the Windows shortcuts,
  4. look for the Toggle shaded state shortcut entry and
  5. edit it to a different or no key combination.

This applies to at least Unity and GNOME since they both use the same settings entries to determine keyboard shortcut combinations.

It's possible that the key combination is not bound to the same shortcut as in OP's case, in which case you need to look through all shortcut entries for one that has the key combination in question.

3
  • 4
    any idea about 18.04 LTS? The for d in /org/gnome/settings-daemon/plugins/media-keys/ /org/gnome/desktop/wm/keybindings/ /org/gnome/settings-daemon/plugins/power/; do dconf dump "$d"; done | grep -iFe '<Control><Alt>S' does not result in any output.
    – damjad
    Sep 23, 2018 at 14:20
  • @chuckskull: You can always look through the list of keyboard shortcuts manually. There aren’t that many after all. In theory the settings dialogue should unbind previously bound combos if you try to reuse them; thus you can bind the affected combo to something and then unbind it again to also unbind it from any other function. Otherwise could you please open a new question if you have a new or follow-up question? The comment section is not suitable or meant for new questions or extended discussion. You’re welcome to send me a comment with a notification to draw my attention to it. Thanks. Sep 23, 2018 at 14:39
  • It's nowhere in the list in Ubuntu 20.04 for me. The below dconf answer did the trick. Jan 12 at 19:22
3

In such case dconf reset /org/gnome/desktop/wm/keybindings/toggle-shaded makes a deal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.