21

When typing either of the commands nautilus . or xdg-open . into terminal, they execute correctly, but with a warning:

Nautilus-Share-Message: Called "net usershare info" but it failed:
Failed to execute child process “net” (No such file or directory)

As I say, it opens the file manager correctly and I can detect no further problems. There are several instances of users experiencing this message in other questions (1)(2)(3), but each of the questions either addresses a side-issue I'm not experiencing, or simply goes unanswered.

What does this message mean, and can I do anything to prevent it?

6
  • 1
    It looks like the warning is caused by the "nautilus-share" package (a Nautilus extension). If you're not using it, you can remove that package.
    – Logix
    Apr 13, 2018 at 9:20
  • … or try reinstalling it with sudo apt install --reinstall nautilus-share.
    – dessert
    Apr 13, 2018 at 10:13
  • 3
    Interesting... reinstalling with sudo apt install --reinstall nautilus-share appears to not work, while calling sudo apt-get remove nautilus-share and then sudo apt-get remove nautilus-share separately appears to have resolved it. Apr 13, 2018 at 10:21
  • @preferred_anon If that worked kindly post that as an answer and mark that as accepted answer.
    – Kulfy
    Nov 28, 2018 at 17:00
  • I think it worked on my old machine, but trying it on my current one did not resolve the issue. @Yavuz Selim's suggestion worked, so I've accepted it. Nov 30, 2018 at 9:02

1 Answer 1

26

Error says, net command not found, so I tried net command. Ubuntu suggested me to install samba-common-bin

Command 'net' not found, but can be installed with:

apt install samba-common-bin

So, I've installed that package.

sudo apt-get install samba-common-bin

That error gone, but in my case new error was thrown.

Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory

And then I've created directory

mkdir /var/lib/samba/usershares

Finally, I have no error.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .