1

I am trying to get 3D stereo (stereoscopic vision) to work on our xubuntu machine using an NVIDIA geforce graphics card, and NVIDIA 3D vision glasses. I have (tried) to follow the many suggestions but cannot get 3D stereo to work on our xubuntu machine. I read that it should work with the NVIDIA GEFORCE graphics cards above the 400 series, so we thought we would try.

Here is the output of glxgears: 603 frames in 5.0 seconds = 120.411 FPS 600 frames in 5.0 seconds = 119.988 FPS

glxgears -stereo Error: couldn't get an RGB, Double-buffered, Stereo visual

Our set up is as follows: Ubuntu 16.04.4 LTS Codename: xenial Xubuntu with XFCE desktop environment.

Acer monitor that is “Nvidia 3D vision ready”.
Nvidia GeForce GT 710 graphics card.
Nvidia 3D vision emitter and glasses.

If I issue the command inxi, it shows our computer setup:
CPU~Quad core Intel Core i7-4790 (-HT-MCP-) speed/max~3803/4000 MHz Kernel~4.4.0-119-generic x86_64 Up~1 day Mem~1363.1/3886.2MB HDD~1000.2GB(36.3% used) Procs~263 Client~Shell inxi~2.2.35

The monitor and emitter work on a Windows 7 machine no problem (the emitter shows a green light). On the xubunt machine, the emitter shows a red flashing light.

I installed the NVIDIA X-server settings GUI.  
I installed the latest NVIDIA driver from the NVIDIA website.  
If I look at Software &Updates>Additional Drivers I see that

“Using NVIDIA binary driver-version 390.48 from nvidia-390” is selected.

lspci | egrep '3D|VGA' 04:00.0 VGA compatible controller: NVIDIA Corporation Device 128b (rev a1)

I edited the /etc/X11/xorg.conf file to include

Option "Stereo" "10" Section "Extensions" Option "Composite" "Disable" EndSection

I have also tried the "nouveau" driver, but no 3D stereo.

Is there another place that needs editing?? Am i using the xorg.conf file? Any suggestions?The programs we wish to use are PyMOL and COOT.

Thanks in advance!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.