2

When I run the command, sudo apt-get install mysql-server, I get the following errors...

Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libevent-core-2.0-5 mysql-client-5.7 mysql-common mysql-server-5.7
Suggested packages:
  mailx tinyca
The following NEW packages will be installed:
  libevent-core-2.0-5 mysql-client-5.7 mysql-common mysql-server
  mysql-server-5.7
0 upgraded, 5 newly installed, 0 to remove and 7 not upgraded.
Need to get 0 B/4,497 kB of archives.
After this operation, 82.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Preconfiguring packages ...
Selecting previously unselected package mysql-common.
(Reading database ... 288832 files and directories currently installed.)
Preparing to unpack .../mysql-common_5.7.21-0ubuntu0.16.04.1_all.deb ...
Unpacking mysql-common (5.7.21-0ubuntu0.16.04.1) ...
Selecting previously unselected package mysql-client-5.7.
Preparing to unpack .../mysql-client-5.7_5.7.21-0ubuntu0.16.04.1_amd64.deb ...
Unpacking mysql-client-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Selecting previously unselected package libevent-core-2.0-5:amd64.
Preparing to unpack .../libevent-core-2.0-5_2.0.21-stable-2ubuntu0.16.04.1_amd64.deb ...
Unpacking libevent-core-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Setting up mysql-common (5.7.21-0ubuntu0.16.04.1) ...
update-alternatives: using /etc/mysql/my.cnf.fallback to provide /etc/mysql/my.cnf (my.cnf) in auto mode
Selecting previously unselected package mysql-server-5.7.
(Reading database ... 288884 files and directories currently installed.)
Preparing to unpack .../mysql-server-5.7_5.7.21-0ubuntu0.16.04.1_amd64.deb ...
Unpacking mysql-server-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Selecting previously unselected package mysql-server.
Preparing to unpack .../mysql-server_5.7.21-0ubuntu0.16.04.1_all.deb ...
Unpacking mysql-server (5.7.21-0ubuntu0.16.04.1) ...
Processing triggers for systemd (229-4ubuntu21.2) ...
Processing triggers for ureadahead (0.100.0-19) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up mysql-client-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Setting up libevent-core-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...
Setting up mysql-server-5.7 (5.7.21-0ubuntu0.16.04.1) ...
update-alternatives: using /etc/mysql/mysql.cnf to provide /etc/mysql/my.cnf (my.cnf) in auto mode
Renaming removed key_buffer and myisam-recover options (if present)
mysql_upgrade: Got error: 1524: Plugin 'unix_socket' is not loaded while connecting to the MySQL server
Upgrade process encountered error and will not continue.
mysql_upgrade failed with exit status 11
dpkg: error processing package mysql-server-5.7 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.7; however:
  Package mysql-server-5.7 is not configured yet.

dpkg: error processing package mysql-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                      Processing triggers for libc-bin (2.23-0ubuntu10) ...
Processing triggers for systemd (229-4ubuntu21.2) ...
Processing triggers for ureadahead (0.100.0-19) ...
Errors were encountered while processing:
 mysql-server-5.7
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

I read through a lot of forums and websites before posting here. The list of things I have already tried :

  1. Ubuntu 15.10 mysql error 1524 - unix_socket | Ask Ubuntu
  2. Changed the my.conf file
  3. purged mysql-* files, reinstalled them
  4. Configure MySQL server on Ubuntu | rackspace.com

I am really stuck so it would be immensely helpful if someone guided me a way out of this.

  • Did you have installed mariadb-server before you try install mysql-server? Do you have any databases in this MySQL instance or it is the clear (new) installation? – mariaczi Apr 12 '18 at 7:23
  • It is a new installation with no database, and yes i did install maria-db before mysql-server @mariaczi – Chintan Mehta Apr 12 '18 at 8:59
1

Try these. Hope it helps.

sudo apt-get remove --purge mysql*
sudo apt-get purge mysql* 
sudo apt-get autoremove 
sudo apt-get autoclean
sudo apt-get remove dbconfig-mysql
sudo apt-get dist-upgrade
sudo apt-get install mysql-server
  • Still the same error persists.. as in the question – Chintan Mehta Apr 12 '18 at 9:02
  • My solution is the same thing as you've written as an answer.. – surjit Apr 12 '18 at 12:49
  • mysql* means all the packages in your system which name starts with mysql – surjit Apr 12 '18 at 12:51
  • I tried that, it did not delete the config files and the dependencies in /var/lib as well as etc/mysql @surjit – Chintan Mehta Apr 13 '18 at 15:55
0

I finally was able to solve the problem by removing all the dependencies and configuration files of the mysql as well as maria-db first. To do that, go to /var/lib and delete all the files related to mysql (You will have to have root permissions to delete them so dont forget to write sudo su before that). You can delete all the files by typing rm -r /var/lib/mysql*.
After that you have to delete all the files in the /etc directory by typing rm -r /etc/mysql*

Then perform the following commands and you will be set to go :

sudo apt purge mysql-client-5.7 mysql-client-core-5.7 mysql-common mysql-server-5.7 mysql-server-core-5.7 mysql-server
sudo apt update && sudo apt dist-upgrade && sudo apt autoremove && sudo apt -f install
sudo apt install mysql-server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.