1

So I am currently having a problem where I cannot boot from a USB and my computer automatically goes to the GRUB screen on startup. My computer came with Windows 10 and I added Ubuntu 17.04 on top of that. I use grub to choose which operating system I want on startup. Now, I want to get rid of my Ubuntu 17.04 partition and download a Ubuntu 16.04 in its place.

I already created a bootable drive and I changed my boot order in my BIOS menu to prioritize my USB first. Even though I have changed the boot order, my computer still goes to my GRUB menu on startup giving me the option of choosing my Windows or Ubuntu partitions.

My computer had no problem booting from a USB before since I have partitioned my hard drive the same way previously. I just cannot get to the USB boot menu anymore and am not sure of how to go about this.

How can I get my computer to boot from USB?

4
  • which of uefi or bios does your computer support? How did you create your bootable drive? Is secure boot turned off? – ptetteh227 Apr 12 '18 at 0:50
  • It could be a BIOS issue. Go into full BIOS and ensure that the UFD is first booting device. I don't just mean use the BIOS boot-order option screen which looks like a boot-manager screen, and enables you to change the boot order temporarily until restart. Use the actual BIOS and its boot tab to get to the boot order. Then save this setting, restart, go back into BIOS and check that the boot order has been saved. If good then try again to boot up from the UFD – Paul Benson Apr 12 '18 at 0:50
  • I created my bootable with online software and an ISO (with Rufus). Secure boot is enabled. BIOS is maintaining my boot order. when I recheck BIOS, the boot order is the one that I changed it to(with the USB drive as the first.) I am not really sure what the setting should be for Legacy or UEFI. My current setting is Legacy. When I change it to UEFI, nothing boots, and it gives me a PXE error. – CJ E Apr 12 '18 at 0:57
  • You would switch to UEFI if your HDD was configured to a GPT drive rather than an MBR, which sounds like the latter. Do you already know which type it is - GPT or MBR? Rather than go into all that, try disabling Secure Boot for now. Also alter the first boot order in BIOS to Windows (sometimes named Windows Boot Manager) and see if you can boot straight into that. Remember to save BIOS first. – Paul Benson Apr 12 '18 at 2:54
0

There could be a few reasons why this is the case:

a) For some reason the BIOS is not detecting your applied boot order. Try pressing F12 or the appropriate key for your laptop/PC to get into the "One Time Boot Menu". This should allow you to boot from the USB.

b) The ISO you downloaded could be corrupt. Try re-downloading the ISO and putting it on the USB again.

c) The USB could have bad sectors/some other critical problem. Try using a different USB.

d) You have not put the ISO on the USB correctly. You might like to see one of create a Ubuntu USB stick on Windows, create a Ubuntu USB stick on Ubuntu or create a Ubuntu USB stick on Mac OS X.

1
  • Hey, I tried all of the above. When I used the one time boot menu, the computer still went to grub for some reason. I then tried recreating the bootable drive on multiple USBs, none of which worked. My current solution is looking at deleting the Linux partition manually and then overriding the linux boot loader using a windows recovery drive. After that, I will just attempt to redownload a fresh Linux install. Is this potentially dangerous? Because it seems like I am out of any other options :/ – CJ E Apr 11 '18 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.