12

I was looking through my logs and I found this at the top:

[pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

I have no idea what it means. My computer starts fine, and I haven't noticed any errors so far. But just to be safe, does anyone know how to resolve this?

Also, just to be clear, I've read the error and I can see the 'possible causes' part, but I don't know what it means by 'remote application' or 'message bus security.'

0

The short answer is to execute the following command:

cp /usr/share/gdm/default.pa ~/.config/pulse/

The explanation:

By googling around a bit I found that pulseaudio is the audio subsystem in Ubuntu nowadays, and the pactl command can be used to fiddle with its settings.

This command has quite a few subcommands, the most interesting of which is list.

By executing pactl list short you can see that there is a module that contains the word bluez in its name, and it is bluetooth related.

I am using a desktop computer which is not equipped with bluetooth, so there should be no bluetooth-related modules running.

Executing pactl unload-module for each bluetooth-related module did not work, because on reboot the modules were loaded again, and so the error appeared in the log again. One should take hint from the fact that pactl is billed as a program to "Control a running PulseAudio sound server": it does not actually modify the persisted configuration of the sound server.

By googling around a bit more I found that PulseAudio settings are stored in some default.pa file, and I found two instances of this file on my system, a fat one under /etc/pulse/ and a skinny one under /usr/share/gdm/.

Obviously, the fat one is global PulseAudio settings, and the skinny one is user-specific settings somehow related to the gnome desktop manager.

The contents of the user-specific default.pa were very interesting, as it contained commands to do precisely what I wanted to do: disable the bluetooth-related modules. It does not disable the bluez module per se, but by fiddling with pactl earlier I discovered that disabling the other two bluetooth-related modules has the effect of automagically also disabling the bluez module.

Only problem is, gdm's configuration file is kind of useless to me, because it does not get executed when I log in.

By googling around even a bit more I found that the location for a user-local instance of this settings file is supposed to be ~/.config/pulse/default.pa.

Hence, I reasoned that if I just copied gdm's file to this location on my profile, the problem would be fixed.

And indeed it has.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.