I have a lot of 5.1 flac files. They play just fine, apart from not every channel will be downmixed at the right volume to the two speakers in my headphones while playing. This is the same no matter what player I use (vlc, ffplay, mpv, parole)

The front two, centre and LFE tracks are downmixed, and I hear them, but the rear two are very quiet.

A quick speaker-test shows this to be true.

How can I fix this? So far alsamixer has been totally unhelpful, as it never seems to display each virtual speaker, just a master volume, PCM, etc.

EDIT: I installed paman, and it shows how the sound goes from the sink input as "s16le 6ch 48000Hz" and somehow becomes "s16le 2ch 48000Hz", but during that process the channels are butchered and mixed wrong. What kind of malformed wizardry is this? Where can I find a mixer that will fix this?


  • Would you mind reviewing the other answer again? As it was the first one posted, if it works you can accept it instead of mine. Thank you. Apr 15, 2018 at 19:35

2 Answers 2


New version using pavucontrol

First install the app:

sudo apt install pavucontrol

Then call it from the launcher by typing the first few letters pav and selecting the icon. Follow the .gif below to click on the individual speakers and set their volume:

pavucontrol individual speaker volume

Original version not working

Your question "What kind of malformed wizardry is this?" can best be answered with this command:

$ grep channels /etc/pulse/daemon.conf
; default-sample-channels = 2

Using sudo powers edit the file /etc/pulse/daemon.conf and change the line:

; default-sample-channels = 2


; default-sample-channels = 6

Save the file and exit your editor. To restart pulse audio use:

pulseaudio -k
  • I've tried this already, and unfortunately... it didn't work at all. Made no difference at all, in fact.
    – Nectar
    Apr 14, 2018 at 20:39
  • @Nectar Sorry to hear that. I was going to delete this answer but decided I'll leave it so others don't post the same thing. Leave me a comment if you add this information to your question and I'll delete the answer. Thanks. Apr 14, 2018 at 20:42
  • I'm trying to downmix, remember. :) So I think a volume control is what I need, it's just a question of where.
    – Nectar
    Apr 14, 2018 at 20:43
  • @Nectar I revised the answer with individual speaker volume. Hope this helps. Apr 14, 2018 at 20:59
  • That's fantastic. Thanks a whole bunch. :)
    – Nectar
    Apr 14, 2018 at 21:43

I had similar problems with a KDE Neon installation. The solution was installing the PulseAudio Manager (Do not worry, it uses a GUI):

sudo apt -y install --no-install-recommends pavucontrol

Then go to the Configuration tab, and test with the available sound configurations. You can also try setting the application/system volume in the Output Devices tab.

  • 1
    There's nothing in there that's useful, I'm afraid. There's no separate volume controls or anything like that. I can choose from Stereo Duplex, Off, Stereo Input, and Stereo Output. I am trying to downmix, so I need some seperated volume controls for each speaker.
    – Nectar
    Apr 14, 2018 at 20:44
  • I asked OP to accept your answer instead of mine. I think we can ask a mod to change the bounty. Apr 15, 2018 at 20:37
  • @WinEunuuchs2Unix Thank you, do not mind about the bounty, just wanted to be considered part of the solution. Apr 17, 2018 at 7:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.