11

I use a Ubuntu 16.04 with Nginx and Certbot.

I tried to execute, for example:

certbot -v
certbot -V
certbot --version
man certbot

none gave any relevant output. How could I know the version currently installed in my Ubuntu?

3
  • What Ubuntu are you on? Are you using the Certbot PPA or no?
    – Thomas Ward
    Apr 10, 2018 at 16:11
  • Updated the question. Yes I downloaded a PPA (I think "downloaded" is correct), and only then I could install Certbot. Apr 10, 2018 at 16:13
  • This question is misleading. certbot --version is the correct syntax here. If you do not have certbot installed and you type that, it will generate the error certbot: command not found. This is not a sign of incorrect syntax, but rather, the sign that it is not installed. If it is installed, this command will output the version, at least in all my experiences working with it (and I've used some pretty old versions, well before 1.0.)
    – cazort
    Sep 9, 2021 at 19:23

2 Answers 2

14

14.04 and 16.04 systems (and NOT using the PPA):

Ubuntu Trusty and Ubuntu Xenial both do not have certbot installed by default. To get Certbot, you had to be using the Certbot PPA maintained by the Certbot developers.

If you are not using the PPA (which you would have installed using sudo add-apt-repository ppa:certbot/certbot), you don't have Certbot.

To get Certbot, you should read through the instructions on the Certbot Website by choosing your specific release, and then follow the guide to set up Let's Encrypt.


14.04/16.04 systems using the PPA, or Ubuntu 17.10 or later:

At the time of this post, Ubuntu releases 16.10 and 17.04 are past End of Life and not included for this answer.

As of 17.10 (and potentially earlier, see my note above), Certbot is included in the repositories.

And if you are on older Ubuntu (14.04 or 16.04), and you are using the PPA, then certbot is available.

To find the version of Certbot installed, you can use apt-cache policy certbot | grep Installed to get the information, as shown below (note that the version information shown below is accurate as of April 10, 2018 at 12:18, on a brand new 'certbot' installation):

$ apt-cache policy certbot | grep -i Installed
  Installed: 0.22.2-1+ubuntu16.04.1+certbot+1

As you can see, version 0.22.2 is installed on this computer here, which is a 16.04 machine using the Certbot PPA.

1

If you did not get the certbot with apt like @Thomas Ward said, you will get it with the wget command as a stand-alone application instead.

Try this command below:

sudo /PATH/TO/certbot-auto --version
3
  • I recommend to edit this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.)
    – abu_bua
    Aug 27, 2018 at 14:52
  • +1. Wonder why this answer did not have any votes. This was most straightforward answer to the question asked and worked well for me
    – Anupam
    Dec 16, 2019 at 7:18
  • Admittedly finding the version of certbot is challenging. However, this answer 1) runs certbot auto and in my case unexpected performed some "upgrades" without confirmation, and 2) after the upgrades finished reported certbot 1.4.0, which was not the version of certbot reported by the procedure at askubuntu.com/a/1023717/550780 (I suspect it is the version of certbot-auto rather than certbot proper).
    – CODE-REaD
    May 20, 2020 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.