0

I am using two monitors, and Ubuntu 17.10 .

There are some times, that one monitor will not display, after I boot into Ubuntu. It will return to work only after I unplug it and plug it again.

It seems that all the programs that I open will use the second monitor as well, and I can use the mouse on the second monitor, But the monitor doesn't display anything, just black screen.

Also, when I re-plug the monitor, Ubuntu doesn't seem to refresh anything, like it already knew that the screen was connected.

EDIT: Another thing I forgot to mention, when I get the login screen both monitors will work normally, only after I log in, the issue starts.

EDIT: It also happens on Elementary OS Loki, which means the problem is on the Ubuntu 16.04 lts version as well.

Is there any solution for this issue? Thank you very much in advance :)

  • Do you know if you use x11 or wayland? – Ott Toomet Apr 10 '18 at 17:02
  • @OttToomet Wayland – Argaman Apr 11 '18 at 6:37
  • 1
    Don't really know Wayland... I have a little bit related issues with x11 -- have to run xrandr --auto several times sometimes to get the other monitor up. I have mapped this command as a keyboard shortcut so no big issue. Not sure how Wayland works here... – Ott Toomet Apr 11 '18 at 22:32
  • @OttToomet Thank you for trying to help anyway :) – Argaman Apr 12 '18 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.