0

I have already searched for all the related and numerous posts with regard to the terminal not starting up and tried most of the solutions. But am still stuck with my terminal not opening. I tried to make Python 3.6 my default according to this tutorial and that's where things started going downhill. Now am unable to open the terminal.

Option 1

So I tried reconfiguring the locales using the following in the non-graphical terminal(Ctrl+ALt+F1).

$ sudo dpkg-reconfigure locales
$ sudo upgrade-locale LANG=en_US.UTF-8 LANGUAGE=en_US

Then upon checking the /etc/default/locale file, I was able to observe that both of these have been successfully updated in the file.

I also rebooted the machine. But am still not able to start the terminal.

Option 2

I tried starting the terminal manually on xterm (Alt+F2) using gnome-terminal and I get the following output/error description.

enter image description here

Any suggestions will be much appreciated.

1

I just scraped through a few more solutions and finally stumbled upon the following that actually solved my issue. So I thought of posting it in case anyone else faced the same issue.

sudo rm /usr/bin/python3
sudo ln -s python3.5 /usr/bin/python3

This was a problem with the system applications that have already been relying on python 3.5. The issue was in relation with symlink python3.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.