I need to configure wireless network. To do it I need to install CA certificate. How to do it in ubuntu?

  • these setting worked for Ubuntu 12.04 as well.Thanks a tonn – user324020 Sep 5 '14 at 17:08

I had a similar problem ubuntu 13.04. I selected Protected EAP (PEAP) for authentication mode, and ignored choosing a certificate file.

Now I am connected successfully with the following settings.

enter image description here

  • 1
    Thanks, that worked for me! Wonder what this actually changes tho.. – ocean800 Sep 17 '15 at 0:29
  • @ocean800 This drops the server authentication. Basically, you can no longer be sure you are actually connected to an access point of the network you wanted to connect to. You may want to read up on man-in-the-middle attacks. – valid Sep 12 '16 at 13:22
  • @valid So, what is the best (most secure+easy to configure) setting? – antmw1361 Oct 4 '16 at 9:59
  • 1
    @antmw1361 "Secure" and "easy" are conflicting interests. I'd advise to use certificates and encourage access point owners to have an easy-to-use, properly certified network. Wireless hotspots without cert can be exploited by .. future security experts - the kind that notice your picture's background saying "for? Browse other questions tagged networking wireless" ;). Then again, I also, at times, had priorities that required me to ignore outdated or otherwise improper certificates. It's a good start to feel at least irritated in those cases. – valid Oct 6 '16 at 10:31

Some wireless networks use a Certificate Authority file which can be configured in the following place:

Network menu (the four spreading arcs icon) > Edit Connections... > choose your network > Network Security tab > pick "WPA & WPA2 Enterprise" from the pop-down menu > CA Certificate.

(My own use for a CA file is a VPN that requires me to install a CA in my browser. That doesn't seem to be your case.)

There is no need to "install" a ca-certificate for wireless networking.

try this http://www.engin.umich.edu/caen/network/wireless/docs/linux.html

I used the AddTrust_External_Root found in the mozilla certificates - /usr/share/ca-certificates/mozilla/AddTrust_External_Root.ca

Wifi worked.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.