7

I have two monitors on a NVIDIA card. KDE combines the second monitor with TWinView to all my virtual desktops. While this is nice I'd rather had an additional virtual desktop (let's say desktop #5) fixed to my second monitor while switching beetween desktop #1 to #4 on my first monitor.

Can this been done? (KDE 4.8, Ubuntu 11.10)

At the monent I can only use the following workaround: drag an application to the second monitor on desktop #1 and apply "fix to all desktops" on the window in question. Then when switching desktops the window shows on all of them but is fixed to a position on the second monitor. While this works it'd be more convenient if I could have an independent desktop on my second monitor with it's own activities; panels and stuff. And when starting an application there it should stay there also ...

I also tried to configure the second monitor as individual X-Server-Dislpay. But then still I can't send running applications over to the second screen ...

2 Answers 2

9

This answer is for KDE 4.x. For KDE Plasma 5, check out the other answer m0h17.


I'm actually running KDE 4.9.4 atop ArchLinux, but it shouldn't matter. Since KDE treats the screen as one (mostly), switching Virtual Desktops will switch them on all screens. However, there's a handy "On all Desktops" button in every window titlebar (near the app logo, you enable/disable that in SystemSettings->WindowDecorations->ConfigureButtons). Click that, and your application will remain there even if you switch the desktops. It's a workaround, but it works.

1
  • thx barraponto, I changed my setup, but now I will try to fix this again with your suggestion. I let you know here whther it woks - thx a lot!, piedro
    – piedro
    Jan 25, 2013 at 7:38
2

Use the Virtual Desktops Only On Primary script from https://github.com/wsdfhjxc/kwin-scripts

Clone the repo, and run the script.

git clone https://github.com/wsdfhjxc/kwin-scripts.git
cd kwin-scripts/
./helper.sh install virtual-desktops-only-on-primary

After installing the script, go to System Settings > Window Management > KWin Scripts and enable the Virtual Desktops Only On Primary script.

enter image description here

There will be no need to manually set the Window Settings every time.

1
  • 1
    This is working great. Thank! Jul 4, 2022 at 10:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .