0

after an update I rebooted only to find out that I lost some kernel module, wl is no longer there (meaning I no longer have wifi) also my battery is acting up because acpi no longer find my battery... this is bad because I can no longer shutdown properly (since acpi think my laptop is now a desktop...) I also have random freeze when idle...

that said I use a minimal install with wicd for network so resolv.conf is not applicable here.

mprobe show that the wl module is not installed (it was before the update)

acpi report that it cannot run with (power_supply) again a missing kernel module ?

booting in an older kernel is irrelevant since there is no modules installed (yay)

my question is how do I install those module back ?

note: I am not using the original wifi card. I am using a Centrino N-6235.

edit: here is the output for

sudo modprobe iwlwifi && dmesg | grep iw
[   27.698508] iwlwifi 0000:04:00.0: found PCI INT A -> IRQ 6
[   27.973964] iwlwifi 0000:04:00.0: loaded firmware version 18.168.6.1op_modeiwldvm
[   28.364123] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEBUG disabled
[   28.364125] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[   28.364127] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled   
[   28.364129] iwlwifi 0000:04:00.0: Detected Intel(R) Centrino(R) Advanced-N 6235 AGN, REV=0xB0
[   28.377155] iwlwifi 0000:04:00.0: reporting RF_KILL (radio disabled)
[   28.440126] iwlwifi 0000:04:00.0: RF_KILL bit toggled to disable radio.
[   28.581807] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   31.410345] iwlwifi 0000:04:00.0 wlp4s0: renamed from wlan0

this is for the command rfkill list all

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Edit 2: I completely forgot that I tried to fix the freeze issue by blocking acpi ... at the time it did noting, that kernel update must have correctly read the config file and actually blocked apci removing access to the battery info and blocking the wifi card for some odd reason, apparently it hard block the card.

I used the cstate bug fix and no more freezing issue. Handling questions about the Bay Trail c-state bug I probably should have read that before trying to fix the problem in a random way.

  • 1
    "I am not using the original wifi card. I am using a Centrino N-6235." The driver for this is not wl; it is iwlwifi. Please edit your question to show the output of the terminal commands: sudo modprobe iwlwifi && dmesg | grep iwl and also: rfkill list all. – chili555 Apr 7 '18 at 18:17
  • regarding the battery situation it seems to be the same as bugs.launchpad.net/ubuntu/+source/linux/+bug/1179010 – GothSparkImvu Apr 7 '18 at 20:51
  • I can't answer the battery issue, but the wireless is likely this: askubuntu.com/questions/895617/… – chili555 Apr 7 '18 at 21:21
  • still no wifi the laptop does not have a physical switch ... wifi is working in windows so ireally have no clue as to what is going on – GothSparkImvu Apr 7 '18 at 22:15
  • 2
    F7 is Airplane Mode. That's the same thing. Press it and check again: rfkill list all – chili555 Apr 7 '18 at 23:34

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.