1

I am a new user, trying to install a downloaded tar.bz2 package. I have extracted the files into a folder on my desktop. I am trying to follow the directions here: How do I install a .tar.gz (or .tar.bz2) file?

But they say "Make sure you read a file called INSTALL, INSTALL.txt, README, or something similar if one was extracted." But I don't see a file with that name. What should I do?

  • 1
    Don't you have a README file? What are the contents of the package? Isn't there a installation instruction at the source from where you got the package? – pomsky Apr 7 '18 at 12:08
  • 1
    It might be helpful if you provided a link to the tarball (.tar.bz2) archive you downloaded, or where you got it, so we can see what is inside and what the README is actually called. – guiverc Apr 7 '18 at 12:08
  • Hi, what software do you want to install and on which OS (Ubuntu, ...)? Have you tried to compile the software (after changing into the extracted directory) as described above? Are you sure, the package contains a C / C++ source code? – Stefan Apr 7 '18 at 12:10
  • The package is monero-gui-linux-x64-v0.12.0.0. It has a file titled "start-gui.sh" which I opened. I don't know if it's the right one tho. The contents of that file say: – user815824 Apr 7 '18 at 12:25
  • #!/bin/bash export LD_LIBRARY_PATH=pwd/libs export QT_PLUGIN_PATH=pwd/plugins export QML2_IMPORT_PATH=pwd/qml # make it so that it can be called from anywhere and also through soft links SCRIPT_DIR="$(dirname "$(test -L "${BASH_SOURCE[0]}" && readlink "${BASH_SOURCE[0]}" || echo "${BASH_SOURCE[0]}")")" "$SCRIPT_DIR"/monero-wallet-gui – user815824 Apr 7 '18 at 12:25
1

You have downloaded Monero GUI Linux 64-bit 0.12.0.0 Lithium Luna, from official link I hope.

So you have monero-gui-linux-x64-v0.12.0.0.tar.bz2 file in your ~/Downloads folder. Then you can extract it by any known way.
The folder monero-gui-v0.12.0.0 will be created here.

This directory has start-gui.sh, you can click on it or run it from terminal with ./start-gui.sh.

  • Thanks - that worked. Clicking on the file did not start it up but the command line worked. – user815824 Apr 7 '18 at 12:42
  • Then you can accept my answer :) – N0rbert Apr 7 '18 at 12:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.