4

I have installed the Messenger for Desktop app on my 16.04. Everytime I launch the application I get this javascript error seing on screenshot below

enter image description here

However when I click OK the the app launches properly. I haven't detected any issues so far, however I was wondering if anyone else has faced the same issue and how to solve it.

Edit I have noticed that I don't get a notification or any indication when some of my contacts texts me when the app is minimized. I'm not sure if this is a bug occured from this issue or whether is missing from the linux version in general (which probablly is still a bug)

  • I have the same issue. It happened for first time about a week agoo. – pa4080 Apr 6 '18 at 21:33
  • So its probably a bug of the app?? – ltdev Apr 6 '18 at 21:36
  • I just write a feedback (Help->Send Feedback) with the following content: Hello, I'm using Messenger for Desktop v2.0.9-stable on Ubuntu 16.04, a week ago the app started to throw the following error message: JavaScript error in the main process. Also some conversations doesn't show. Please see this Question on AU: https://askubuntu.com/q/1022676/566421 – pa4080 Apr 6 '18 at 21:51
  • 1
    Lykos, try to switch off the option "Check for Update Automatically" from the menu "App", I suppose this could suppress the error message. – pa4080 Apr 6 '18 at 22:00
3

Temporal workaround that I found is to switch off the option "Check for Update Automatically" from the menu "App". This will suppress the message "JavaScript error in the main process". In result the overall behaviour of the application will be improved.

enter image description here

Further when I check for updates manually, "Checking for Update..." process never finish (as you can see on the image above) or finish with the following error message.

enter image description here

Apparently there is a problem with their update server.

| improve this answer | |
1

I got this and it worked fine.

Switch update channel to DEV and download the new update. After installing new update, the application should work fine.

| improve this answer | |
1

Yes, this error is very annoying. I did the following:
I downloaded the package

messengerfordesktop-2.0.9-linux64.tar.gz 

and unpacked it into a separate folder, which I put in the TEMP. Then I created a launch shortcut on the desktop. Everything does work fine and without the boring window, as it always worked.

| improve this answer | |
  • Welcome to Ask Ubuntu! I recommend to edit this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – abu_bua Aug 21 '18 at 16:48
0

If you click OK and app won't start, go to app directory (you can find it out by typing which messengerfordesktop) and try run the app as root. App will start, then uncheck "Check for Update Automatically" as pa4080 proposed. It solved the problem on my Kubuntu 18.04.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.