0

I have a problem with making a new folder in one of my drives. I have ubuntu 17 and the drive format is NTFS.

I already mounted it but I still can't make a new folder.

  • You'll have to give details of what you tried and the response. What is the exact error? – L. D. James Apr 6 '18 at 18:59
  • 1
    Maybe the partition is mounted read-only. Please edit your original question to add the output of the following long command line, which should show if and how the drive is mounted, for i in $(lsblk -l -f|grep -i ntfs|cut -d ' ' -f 1) /etc/mtab;do grep "/dev/$i" /etc/mtab;done ; Indent each line 4 spaces to render the output as 'code'. (You can copy and paste the command line as well as its output to avoid typing errors.) – sudodus Apr 6 '18 at 19:06
  • @sudodus /dev/sda2 /media/mo/0A9392143BD31443 fuseblk ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0 /dev/sdb1 /media/mo/My\040Passport fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0 – mohsen74persian Apr 6 '18 at 20:10
0

Two partitions with NTFS file systems were found.

$ for i in $(lsblk -l -f|grep -i ntfs|cut -d ' ' -f 1) /etc/mtab;do grep "/dev/$i" /etc/mtab;done
/dev/sda2 /media/mo/0A9392143BD31443 fuseblk ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0
/dev/sdb1 /media/mo/My\040Passport fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0 
  • /dev/sda2 is mounted read-only ro
  • /dev/sdb1 is mounted read-write rw

I think default_permissions,allow_other should make it possible to write files and create a directory when mounted read-write.

You cannot write anything (and not create a directory) when a Microsoft partition is mounted read-only.

Try to check permissions with the following commands

ls -ld /media/mo/0A9392143BD31443
ls -ld /media/mo/'My Passport'

See this link with detailed instructions how to mount an NTFS or FAT32 partition to make it useful,

How do I use 'chmod' on an NTFS (or FAT32) partition?


Edit: If Windows is hibernated or semi-hibernated (alias Fast Startup), the Windows file system(s) are not ready for writing by linux, so linux (and Ubuntu is linux) does not want to mount it with write permissions.

What about your partition /dev/sda2? Please check, and if necessary, turn off Fast Startup in Windows and try again.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.