0

Recently I installed lubuntu 17.10 on my old HP mini 2140 because it says it is designed for old systems, and so far is going great! But I encountered a few problems after the installation. Even though after I finished installing Lubuntu i rebooted my machine and on start up i had a black screen on the top left corner, that covered 2/3 of the screen.

After reading some other posts about solution I managed to boot the system in "nomodeset" mode and it worked fine, but the resolution was pretty bad. I made it so it boots up that way everytime, and now I don't have to worry about the black box, but the resolution is really bad and when I try to do something it is very blurry.

I tried installing drivers for my integrated intel video card (intel GMA 950) and I think I did something, but I still do not have the option the increase the resolution. I also tried adding new resolution (1024 x 576, which is the maximum for my laptop) using cvt 1024 576 and then xrendr to add it as a mode, and I make it available.

But when I type xrandr -s 1024x576 it says it cannot change it, and also once I reboot the machine the whole thing is gone, so only the 640x480 is available. I'm pretty new with linux, so I would really appreciate if anyone can help me.

Thank you very much, - turb0

0

Ok guys so I actually found a solution to my own problem :D

I updated the version of my Kernel to the newest available one that is on the Ubuntu website, then restarted the laptop and removed the nomodeset command. After that I booted my laptop and it recognized all the possible resolution there are. Hope this helps anyone with the same issue that I had.

  • turb0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.