1

I'm trying to install Postgresql on this Droplet, and the installation can't go through. This is the error I'm getting.

root@testplatform:/usr/bin# sudo apt-get install postgresql postgresql-contrib
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  postgresql postgresql-contrib
2 upgraded, 0 newly installed, 0 to remove and 243 not upgraded.
3 not fully installed or removed.
Need to get 0 B/10.1 kB of archives.
After this operation, 0 B of additional disk space will be used.
dpkg: unrecoverable fatal error, aborting:
 unknown user 'hplip' in statoverride file
E: Sub-process /usr/bin/dpkg returned an error code (2)

I've tried this solution:

sudo -i    
mkdir /tmp/dpkg    
cd /tmp/dpkg

#i386 version
wget https://launchpad.net/ubuntu/+archive/primary/+files/dpkg_1.18.4ubuntu1.1_i386.deb    

or

#amd64 version
wget https://launchpad.net/ubuntu/+archive/primary/+files/dpkg_1.18.4ubuntu1.1_amd64.deb    

tar x dpkg*.deb data.tar.gz    
tar xfvz data.tar.gz ./usr/bin/dpkg    
sudo cp ./usr/bin/dpkg /usr/bin/    
sudo apt-get update    
sudo apt-get install --reinstall dpkg

I'm still a newbie in this department so I'm completely lost on what I should try next.

This is my uname -a output:

Linux testplatform 3.13.0-79-generic #123-Ubuntu SMP Fri Feb 19 14:27:58 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Also, what the hell is hplip? I can see that it's some kind of a driver for an HP printer or whatever, but it's a damn droplet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.