8

So I noticed that the fans of my Dell XPS 9560 kick in whenever I'm watching YouTube. I looked at CPU usage with top and powertop and 'Web Content' uses 50-90% of CPU. I googled a ton and it appears that Firefox just does not use hardware acceleration on Linux. So I followed every guide out there, changed every about:config line that is spoken of but the CPU usage is still the same. This is really annoying to me as I watch a lot of YT and my laptop is pretty powerful so this should not be the case. I tried both the Intel and Nvidia GPU but that is not the issue. Has somebody here found a solution?

I really searched all of AU and google but none of the solutions so far work.

Specs:

  • Intel i7-7700HQ
  • 16 GB DDR4 -2400MHz

Cheers

  • Have you tried installing the latest Nvidia drivers? askubuntu.com/questions/851069/… – Katu Apr 5 '18 at 8:51
  • I have not, but I use prime to select between GPU's, and I am only using the Intel GPU for the moment. I believe I have 390 installed. But when I googled the issue it was pretty clear that browsers somehow have a problem with hardware acceleration on Linux... – Nicolas Grossen Apr 5 '18 at 9:15
0

I have found this: https://www.pcsuggest.com/chromium-hardware-accelerated-video-decoding-linux/

it appears to work, CPU usage is very low with this ppa. But the downside is the process of installing the API's. I went through every step on this page: https://launchpad.net/~saiarcot895/+archive/ubuntu/chromium-beta

but it still does not work. I am done for today, maybe I'll try to figure out why it does not work later.

EDIT: simply rebooting worked!!

EDIT2: but the CPU usage is high again :(

FINAL EDIT: You have to enable gpu blacklist flag, and then everything works :)

  • 2
    The question is about Firefox. – martinkunev Sep 6 '18 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.