3

I'm trying to use my external gpu (nvidia geforce 750m) on ubuntu . The first problem I encountered was a "system running in low graphic mode error" after installing the recommended nvidia drivers from software & updates. I fixed this error by doing this:

nano /etc/modprobe.d/blacklist-nouveau.conf

and add these lines at the end:

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off

After doing this i could start ubuntu without problems. But the GPU was not recognized and did not show up in the NVIDIA X server settings. In the software & updates the NVIDIA driver was used as the driver for the GPU (and not the nouveau display driver as previously). But details showed that the integrated Intel graphics were still used. I tried this solution. I installed the NVIDIA drivers using this method:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo apt install nvidia-390 nvidia-prime
sudo reboot

After trying the solution and running

 lspci -vvv

i still get this for the NVIDIA card:

01:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 750M] (rev a1)
Subsystem: ASUSTeK Computer Inc. GK107M [GeForce GT 750M]
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 255
Region 0: Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
Region 1: Memory at e0000000 (64-bit, prefetchable) [size=256M]
Region 3: Memory at f0000000 (64-bit, prefetchable) [size=32M]
Region 5: I/O ports at e000 [size=128]
Expansion ROM at f7000000 [disabled] [size=512K]
Capabilities: <access denied>
Kernel modules: nvidiafb, nouveau, nvidia_390, nvidia_390_drm

It seems the correct kernel modules are not loaded, even after blacklisting the wrong ones (see link).

modprobe nvidia
modprobe: FATAL: Module nvidia not found in directory /lib/modules  /4.13.0-38-generic

Sombody know how to fix this (annoying) problem? Thanks in advance :)

  • 2
    Disable Secure Boot in the BIOS. – Pilot6 Apr 4 '18 at 19:44
  • @Pilot6 Thanks! Gpu is showing up in nvidia X server. Guess it was this simple.. – Simon Merckx Apr 4 '18 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.