4

This question already has an answer here:

I built the required module for the 8821ce chip from source (https://github.com/endlessm/linux/tree/master/drivers/net/wireless/rtl8821ce). 2.4GHz wifi is working fine, however 5GHz as well as bluetooth is not available. Do I miss something or is it just not implemented completely by now?

marked as duplicate by pomsky, Thomas, Zanna, karel, waltinator Jul 25 '18 at 15:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Can I ask you which steps are needed to build the module? I downloaded the source files from github. Then tried run the make command but it complains and cannot do that. – user681365 May 23 '18 at 12:33
0

I have the same module in HP Probook 440-G5 and have the same issue, for what I've found, it is not implemented yet :(. So we need to wait until someone implements them.

10

Try that from your home directory

git clone https://github.com/tomaspinho/rtl8821ce.git
cd rtl8821ce/
sudo make all
sudo make install
sudo modprobe -a 8821ce
  • Well, if that works and the OP changes acceptance, ping me and I'll come back and upvote! – Fabby Jun 14 '18 at 18:55
  • 1
    it now supports dkms - so no need to rebuild each time kernel is updated. see github.com/tomaspinho/rtl8821ce – stason Aug 22 '18 at 8:44
  • 1
    works for a Idepad 320 (8821ce) – Diego Andrés Díaz Espinoza Sep 8 '18 at 19:19
  • Works for HP 15-da0403ng, thanks a lot! – Ferdinand Mütsch Dec 5 '18 at 6:44
  • I confirm it worked well on my HP-da0001tx model. I tried many other similar git ways but faced different errors, like gcc error, kernel issues. But this method worked great. I believe there is some difference in git code in all those tried solutions. Thumbs up – Saqib Feb 9 at 20:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.