1

I have the Clipboard Indicator GNOME shell extension installed. How can I create another instance of the extension (for development purposes)?

I created a fork of the original project and cloned the files to

/home/rahi/.local/share/gnome-shell/extensions.

I renamed my working directory to clipboard-indicator@rahi.ca, as the original extension is named clipboard-indicator@tudmotu.com.

I restarted the GNOME shell using Alt + F2 and then r. When I try to enable my cloned extension using the Tweak tool, I do not see a second Clipboard Indicator toggle.

I'm running Ubuntu 16.04 with GNOME shell 3.18.5.

1

Open the metadata.json file located at
/home/rahi/.local/share/gnome-shell/extensions/clipboard-indicator@rahi.ca/
and put "clipboard-indicator@rahi.ca" for the "uuid" entry so that it looks like

"uuid": "clipboard-indicator@rahi.ca",

(i.e. it should match the directory containing the metadata.json file).
You may also want to change the value for the "name" parameter.

Then save the file and restart GNOME shell (or re-login).

Then you should find another instance of the extension in Tweaks > Extensions (I renamed it "Clipboard Indicator for development"):

enter image description here

To learn more about uuid see this.

  • I gave this a try and unfortunately it did not work. – rahi Apr 5 '18 at 12:18
  • @rahi Works pretty well for me: i.stack.imgur.com/NaEIO.png. Should not be necessary, but try changing the "name:" too in metadata.json. – pomsky Apr 5 '18 at 13:04
  • @pmsky YES! changing the name did it! – rahi Apr 5 '18 at 14:12
  • sorry off topic. Can you point us to the theme you're using? – rahi Apr 5 '18 at 16:05
  • @rahi Vimix (beryl variant). – pomsky Apr 5 '18 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.