5

I've installed Ubuntu (tried 17.10 and 18.04 pre-release), since I have a 4k monitor I went to Settings - Devices - Displays and set Scale to 200%.

Everything looks fine until I resize a VM's window (including opening it fullscreen): Ubuntu resets the scale to 100% and everything becomes small.

How can I avoid this and "lock" the scale at 200%?

I tried this with VirtualBox and VMWare Player with the same results. I know there is a "scale factor" in VirtualBox's settings but it is not the same and it makes pictures blurry.

3
+50

Fire up your terminal and type:

gsettings set org.gnome.desktop.interface scaling-factor 2

In virtualbox i tested it, and i can resize vm window without losing scaling. This applies to wayland, so 17.10 is best to test this.

  • I tried with xorg, working on there too. Tested with virtualbox running on ubuntu 17.10 – Pasi Suominen Apr 10 '18 at 16:16
0

I'm using VMWare and Ubuntu 18.04 LTS. I never got gsettings to work right. Maybe that's because I have Wayland turned off, as it is broken on my all my VMWare VMs.

Instead, I use this command: xrandr --output Virtual1 --scale 1.75x1.75, which seems to work well enough. It doesn't resize until after I log in. The command is persistent, so I haven't added it to any startup scripts or anything.

  • I found that for my 192dpi display that I needed to go the 'opposite' direction and set a scaling value of less than 1: xrandr --output Virtual1 --scale 0.5x0.5. – bluemorpho Aug 7 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.