1

I'm looking to install Ubuntu 16.04 onto a new system with two GPU cards, however I can't get farther than the grub boot menu loaded onto the USB install key. Attempting to install (or try) Ubuntu results in multiple device timouts and events logged, and a hard restart required.

I believe I have ruled out hardware issues, using either card individually works fine, and I can install and use windows on the system with both cards installed just fine. If it helps the systems specs are:

AMD Rysen 5 1500X 8 Gbs RAM@ 2400 MHz Gigabyte GA-AB350 Gaming motherboard 2x AMD R9 390

I've attempted to install both Ubuntu 17.10 and the latest version of Mint with similar errors. If there is a better flavor of Linux for dual GPU system compatibility.

I'm not sure what else to try, and I don't have a ton of experience with Linux or Ubuntu (always looking for more), any suggestions are welcome. Also if this is a duplicate issue I apologize, please point me to the correct thread.

  • You already tried all the boot codes (like nomodeset) and nothing lets it boot? Does any linux boot with just one video card installed? – Xen2050 Apr 3 '18 at 1:46
  • With one card (either one, both are verified working), the system works as expected and the install goes smoothly. I'm not too familiar with boot codes, ill look into code nomodeset and others tomorrow. – dvand Apr 3 '18 at 3:27
  • How would I add the boot codes when booting from USB? I don't have the OS installed so I'm not sure how to edit grub in livecd mode... – dvand Apr 4 '18 at 16:48
  • Please turn your last comment to a full answer and write it in the "Your Answer" window below. Then after the waiting period, you will be able to accept the answer as the correct one. Accepting your answer will help others with similar problem. – user68186 Apr 9 '18 at 13:25
  • 1
1

found a solution (not sure if the most optimal one): adding amd_iommu=on iommu=pt before quiet splash in grub allows the livecd to boot and ubuntu to install. once the install was done i had to repeat the process to boot into the new os, and once more to make it permanent by editing /etc/default/grub

0

Turns out that turning off IOMMU in the BIOS also solved this problem on that same motherboard using two RX580 cards in Ubuntu 16.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.