0

I was being unable to access my USB drive. After following the instructions listed here, I found this response:

$ sudo mkfs.vfat /dev/sdb1

mkfs.fat 3.0.28 (2015-05-16) /dev/sdb1: No such file or directory

When I tried to follow the instructions listed here, I found the unmount option (and all other options in the menu) in the Disks GUI utility to be disabled. So I tried to create a partition using the utility and encountered this error:

Error formatting volume

Error wiping device: Command-line 'wipefs -a "/dev/sdb1"' exited with non- zero exit status 1: wipefs: error: /dev/sdb1: probing initialization failed: No such file or directory (udisks-error-quark, 0)

I would appreciate suggestions for a way forward from here.

  • The instructions you linked don't mention wipefs, but anyway, do you have a /dev/sdb1 device? lsblk should show your partitions. Or maybe you just needed to add sudo? – Xen2050 Apr 2 '18 at 21:02
  • @Xen2050, Sorry I forgot to include one of the posts I tried and mistakenly mentioned its response as the response to another post. I have corrected it now. Would you be so kind to go through it once again? – NurShomik Apr 2 '18 at 21:45
0

I have finally solved it with help of GParted. All I had to do was reformatting. Following is what I did:

  • Install GParted:

    sudo apt install gparted

  • Right click on the disk (which was listed with a red exclamation!)
  • Select Format to
  • Select ext4
  • Click on the Apply All Operations button

That solved it!

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.