1

I reset xfwm4 from settings editor. Right clicked on xfwm4 and hit reset. After doing that my title bar won't function properly. I noticed my window buttons changed also the command i use to have dark title bar:

    env GTK2_RC_FILES="/usr/share/themes/elementary Dark/gtk-2.0/gtkrc"

does not work anymore.

I need to revert back to default Xubuntu settings somehow. Before restarting title bar was always white even when using dark themes.

Edit: Sharing more info on the matter. Firstly i think my title bar -using numix theme- was kind of dark before resetting. Also my window buttons were different. Now i see only a cross, before it was a circled cross.

Before options part on title bar was not present even if i set it to O , now it is there when i use O.

I believe some other part was managing my title bar and i just broke that connection.

closed as off-topic by karel, Mitch Mar 6 at 18:28

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced, that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – karel, Mitch
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What about changing to a gtk3 theme? – Arijit Chatterjee Apr 2 '18 at 19:05
  • Reset with this as regular user (no sudo) 'xfce4-panel --quit ; pkill xfconfd ; rm -rf ~/.config/xfce4/panel ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml ; xfce4-panel;' – Arijit Chatterjee Apr 2 '18 at 19:15
  • @ArijitChatterjee I can't really see how that would help though. But i tried and it doesn't work. – anonim Apr 2 '18 at 19:16
  • @ArijitChatterjee I was referring to first comment. Second one didn't work either. – anonim Apr 2 '18 at 19:18
  • Did you reboot after the command? Another option is rm -r ~/.config/xfce4 and then reboot – Arijit Chatterjee Apr 2 '18 at 19:23
1

The XFCE desktop settings for the panels are stored in your home in ~/.config/xfce4/ and you should have the default home files for new users in /etc/skek/.

So you could "reset" your settings by copying the files from /etc/skel/.config/xfce4/ to your /.config/xfce4/ directory.

Then just logging out & in again should reload your desktop (reboot not required).

Using XFCE's own settings windows to change things (themes in Appearance, Desktop, etc) should work.


Since you said there are no files in /etc/skel/.config/xfce4/, you should be able to just erase your current xfce4 files in ~/.config/xfce4/ (possibly using a 2nd account, in case erasing the files while you're logged in might cause them to be re-written on logout) and things should be reset on the next login.

  • There is no xfce4 file in /etc/skel/.config/ – anonim Apr 3 '18 at 19:15
0

I just realised i had to use window manager to change title bar theme. I'm silly, it would be much appreciated if this whole topic is removed.

  • You mean you used "XFCE's own settings windows to change things (themes in Appearance, Desktop, etc)"? That was part of my original answer, if it helped you should upvote it or select it as correct – Xen2050 Apr 10 '18 at 22:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.