I did some searching around but the only topic I managed to find on this was another guy in the Asus forums asking the exact same question but no replies =(.

Basically, can I control the speed for the fans connected to the motherboard in Ubuntu/Mint? I have every header set up as PWM in the BIOS and every fan I have connected to them is PWM-capable but when I run pwmconfig it just comes up saying it found nothing.

Am I missing some steps or is it really not possible?.

➜ sensors
Adapter: ISA adapter
Package id 0:  +30.0°C  (high = +80.0°C, crit = +100.0°C)
Core 0:        +27.0°C  (high = +80.0°C, crit = +100.0°C)
Core 1:        +29.0°C  (high = +80.0°C, crit = +100.0°C)
Core 2:        +24.0°C  (high = +80.0°C, crit = +100.0°C)
Core 3:        +25.0°C  (high = +80.0°C, crit = +100.0°C)
Adapter: ISA adapter
cpu_fan:        0 RPM
➜ sudo pwmconfig
# pwmconfig revision 6243 (2014-03-20)
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.
We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.
/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed

//Edit: Adding more info.

➜ grep nct /proc/modules
pinctrl_sunrisepoint 28672 0 - Live 0x0000000000000000
pinctrl_intel 20480 1 pinctrl_sunrisepoint, Live 0x0000000000000000
  • can I see grep nct /proc/modules – rtaft Apr 2 '18 at 17:45
  • Updated the question with that info. – Laucien Apr 2 '18 at 17:57

I've done this with the Z97 and it looks like the Z170 should work similarly. You will need to configure the /etc/sensors3.conf and /etc/modules to utilize the nct6775 drivers. I was able to get the main fans controlled with the following:


# Chip drivers

Append this to the end of /etc/sensors3.conf

chip "nct6791-*"
    # For the Asus Z97-A. Based on:
    # http://www.spinics.net/lists/lm-sensors/msg42249.html

    label in0 "CPU Vcc"
        # 'CPU Input Voltage' in UEFI
        compute in0  @ * 2, @ / 2

    label in1 "+5V"
        compute in1 @ * 5, @ / 5
        set in1_min 5 * 0.95
        set in1_max 5 * 1.05

        # From driver: label in2 "AVCC"
        set in3_min 3.3 * 0.95
        set in3_max 3.3 * 1.05

    # From driver: label in3 "+3.3V"
        set in3_min 3.3 * 0.95
        set in3_max 3.3 * 1.05

    label in4 "+12V"
        compute  in4  @ * 12, @ / 12
        set in4_min 12 * 0.95
        set in4_max 12 * 1.05

    # in5: unknown

    label in6 "core 3"
        compute in6 @ * 2, @ / 2

    # From driver: label in7 "3VSB"
    # From driver: label in8 "Vbat"
    # From driver: label in9 "Vcore"

    label in10 "GPU"

    label in11 "sys agent"
        # 'CPU System Agent Voltage Offset Mode Sign' in UEFI

    label in12 "core 2"
        compute in12 @ * 2, @ / 2

    label in13 "core 1"
        compute in13 @ * 2, @ / 2

    label in14 "core 0"
        compute in14 @ * 2, @ / 2

    label fan1 "Fan 1"
    label fan2 "CPU fan"
        # The correponding pwm also controls the 'CPU Opt' fan

    label fan3 "Fan 2"
    label fan4 "Fan 3"
    label fan5 "Fan 4"
    label fan6 "CPU fan 2"
        # 'CPU Opt' header

You can also try utilizing sensors-detect, it will generate the /etc/modules file.

Add the following to the GRUB_CMDLINE_LINUX_DEFAULT variable in the /etc/default/grub file: acpi_enforce_resources=lax then rebuild the grub config grub-mkconfig -o /boot/grub/grub.cfg

Again, that was for the Z97, it may need some tweaking for the Z170.

|improve this answer|||||
  • Great, so it could potentially be done with some tweaking. I did some quick testing around though and haven't managed to get it working yet. My sensors3.conf looks like this and it seems to already include settings to nct6791-* and similars. I replaced it with your config just to check if anything changed and still the same. I also manually loaded the nct module with modprobe and nothing either. sensors just reports the coretemp-isa-0000 stuff and nothing else. Seems like I need to do some more research. – Laucien Apr 2 '18 at 19:12
  • It looks like I have that same section as well, in addition to the one I added. I didn't replace the old one. I didn't get access to all of the fans either, just the main ones. I couldn't control the 3 pin ones or the extra thermal sensors, maybe I can if I do some more research, its been a few years. – rtaft Apr 2 '18 at 22:06
  • I forgot one /etc/sysconfig/lm_sensors, updating answer – rtaft Apr 2 '18 at 22:16
  • 1
    So I was trying out the Mint 19 beta and couldn't get this working. I was missing a step from these instructions. Add the following to the GRUB_CMDLINE_LINUX_DEFAULT variable in the /etc/default/grub file: acpi_enforce_resources=lax then rebuild the grub config grub-mkconfig -o /boot/grub/grub.cfg – rtaft Jun 5 '18 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.