0

I have installed ubuntu server 16.04 and the users will work on it through the service XRDP (already installed and configured with the ubuntu-desktop package). The service have been tested and works fine, except with the administrator account but that is other story. The business is, after to have installed the ubuntu-desktop package, when I start the server (local mode) the screen has a graphic interface and not the typical black&white terminal. I would like to know, if is possible install some desktop environment which permits activate it in remote mode only; but keep the classic "terminal" desktop for the admin account in local mode.

Thanks!

  • You can switch TTY 1 - 6 by pressing ctrl+alt+F1 to F6. – pa4080 Apr 2 '18 at 17:58
  • Excellent man, you resolved it! – Javier Mancilla Apr 2 '18 at 18:26
0

Booting Ubuntu without GUI

 $ sudo systemctl disable lightdm

From there, the computer will always default to starting out with in console mode.

If you have need to use the Ubuntu-desktop on that machine, you can start it manually with:

$ sudo systemctl start lightdm

To return it back to the default of booting to the GUI Login screen reinstable lightdm with:

$ sudo system enable lightdm

The available TTY's can still be activated VIA CTRL+ALT+(F1-F6)

|improve this answer|||||
  • Will this also disable the remote desktop GUI? I thought the original poster wanted to retain the ability to RDP while disabling the local GUI. – user68186 Apr 5 '18 at 15:53
  • 1
    @user68186 No. That only affects the local machine. The OP had described using his local machine as a server for remote desktops. That's one of the characteristics of the way a server operates. The remote users can use all the resources of the server, including a full GUI desktop from their remote machines. – L. D. James Apr 5 '18 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.