0

I tried to install cassandra many time by removing it, but it always gives this error:

$ cqlsh

Connection error: ('Unable to connect to any servers', {'127.0.0.1': error(111, "Tried connecting to [('127.0.0.1', 9042)]. Last error: Connection refused")})
  • 1
    how did you install it - via packages, from tarball? what is in the logs, etc.? – Alex Ott Apr 2 '18 at 13:39
  • by using sudo apt get install cassendra – ajit Apr 2 '18 at 13:47
  • what is in the /var/log/cassandra/system.log? – Alex Ott Apr 2 '18 at 14:25
0

First check cassandra is up with this command:

nodestool status

You can see errors in the following log file: /var/log/cassandara/debug.log

0

Try with your hostname after cqlsh followed by the port number.

cqlsh <hostname> <9042>

or

cqlsh <hostname> 

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.