2

I've created a bug report for this issue but I am all out of ideas for investigating the cause. Upon restart, lightdm makes 5 attempts to start before failing at the console screen, and anytime that sudo systemctl restart lightdm is invoked as well. Please see the above link for all attached log files. The last successful reboot was on March 13th, the issue then occurred on March 31st when it was rebooted again.

I have tried purging and reinstalling my Intel graphics drivers. I have tried an older kernel (4.4.0-112-generic). I have also tried purging and reinstalling lightdm and xorg, to no avail. I've also tried refreshing the initrd files:

update-initramfs -c -k all
update-grub

I am able to boot into the desktop using lxdm, but many applications will not launch. For example, Firefox always fails with a segfault, Roxterm will not open, Transmission will not open, and aside from the Firefox segfault, these failures are not showing up in syslog or kern.log. Applications that will open inside the desktop environment (LXDE) include Seamonkey, Lxterminal, and PCmanFM.

  • Looks like your kernel version is 4.4.0-116.140-generic. Have you tried an older one and a newer one? I don't really have a favourite old one but my current favourite new one is 4.14.27. See: askubuntu.com/questions/119080/… – WinEunuuchs2Unix Apr 2 '18 at 7:19
  • Yes, the prior kernel was 4.4.0-112 which also yields the same error. 4.4.0-116.140-generic is the latest one available in my repositories, I have not tried anything newer yet (still reading the link you mentioned). – shellcat_zero Apr 2 '18 at 7:25
  • btw, the 4.14 kernel is the "HWE" kernel which is backported and supported on Xenial, you can read more about it here: wiki.ubuntu.com/Kernel/LTSEnablementStack – dpb Apr 2 '18 at 17:58
1

Apparently, I've had Virtualbox guest utilities installed on my host system which you are generally just supposed to run on the guest. This issue only occurred when the package was updated. After trial and error, the offending package is virtualbox-guest-x11:amd64 (5.1.34-dfsg-0ubuntu1.16.04.2), none of the other virtualbox-guest packages cause this problem.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.