0

I recently got my first flash drive it is a Sandisk Ultraflair 32GB without cloud. I had been waiting for a while to install Ubuntu 16.04, After switching from Linux Mint. I used startup disk creator like the guide on canonical's website. After installing it I wanted to use my flash drive for storage or something else, but I can't delete files, or anything else. with it but boot it on other computers. I then tried to move files to it and it says it is "Read only". When I try to format it in "disks" or delete partitions, it says "This partition cannot be modified because it contains a partition table; please reinitialize layout of the whole device. (udisks-error-quark, 11)" I tried to do FAT and other formats. There are two partitions on the drive currently, "Ubuntu 16.04 partition 1 1.6 GB iso9660" and "ubuntu 16... partition 2 2.4 MB iso..." Can someone help?

0

Maybe try to use 'diskpart' program on Windows to reinitialise partition and reformat flashdrive.

I used this 'diskpart' few times as last help when my pendrive was somehow locked for writing and had much less size than real physical after making it e.g fedora linux startup disk which I wanted then to be Ubuntu startup disk.

Search for diskpart commands on net for clean, make new partition and then format normal way on windows or linux to be able to create properly ubuntu startup disk.

0

Cloned live-only drive

"Ubuntu 16.04 partition 1 1.6 GB iso9660" indicates that it is a cloned Ubuntu system (cloned from the iso file to the USB pendrive). This is correct, but it is a live-only drive with a read-only iso 9660 file system.

As long as you boot from this drive, you cannot change it. But if you boot from another drive you can create a new partition table and file system (alias 'format' it alias 'restore it to a standard storage device').

In Ubuntu

If you have an installed Ubuntu 16.04 LTS system, you can use mkusb-dus to restore it to a standard storage device. See the following links,

help.ubuntu.com/community/mkusb/

sudo add-apt-repository universe  # only for live standard Ubuntu

sudo add-apt-repository ppa:mkusb/ppa  # and press Enter
sudo apt-get update
sudo apt-get install mkusb mkusb-nox usb-pack-efi

help.ubuntu.com/community/mkusb/wipe

enter image description here

In Windows

If you have Windows, you can use Windows tools to format the drive (for example to create a partition with a FAT32 file system).

If still problems

If there are problems to restore the drive to a standard storage device, the following link might help you [solve the problem or at least understand what is the problem],

Can't format my usb drive. I have already tried with mkdosfs and gparted

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.