0

Does anybody have an idea why mute and microphone LEDs on my Lenovo Thinkpad t480s do not light in Ubuntu 16.04.4 LTS?

Tips are appreciated.

  • It doesn't work on kernel 4.13.0-37-generic ; but after an mainline kernel upgrade to kernel version 4.15.15 it works now. – Luckyrings Apr 2 '18 at 8:30
0

Run the following in the terminal

acpi_listen

Now press the button mute button. Then give use the results likely something like this:

ibm/hotkey HKEY 00000080 0000101b

Then open up nano or another text editor.

nano /etc/acpi/events/lenovo-mutemic

And adjust the following for your hotkey.

event=ibm/hotkey HKEY 00000080 0000101b
action=/etc/acpi/lenovo-mutemic.sh

Then we need to make a shells script.

  #!/bin/bash
INPUT_DEVICE="'Internal Mic'"
YOUR_USERNAME="place_your_username_here"
if amixer sget $INPUT_DEVICE,0 | grep '\[on\]' ; then
    amixer sset $INPUT_DEVICE,0 toggle
    echo "0 blink" > /proc/acpi/ibm/led
    su $YOUR_USERNAME -c 'DISPLAY=":0.0" notify-send -t 50 \
            -i microphone-sensitivity-muted-symbolic "Mic MUTED"'
else
    amixer sset $INPUT_DEVICE,0 toggle                       
    su $YOUR_USERNAME -c 'DISPLAY=":0.0" notify-send -t 50 \
            -i microphone-sensitivity-high-symbolic "Mic ON"'
    echo "0 on" > /proc/acpi/ibm/led 
fi

Now let's just make it excutable and restart the service.

sudo chmod +x /etc/acpi/lenovo-mutemic.sh

sudo service acpid restart

There are some other methods but this would likely fix the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.