5

I've seen this question has already posted but I still couldn't find any answers. So basically, when I close my laptops lid and reopen it, instead of showing the lockscreen it boots up from the beginning. Instead of suspending it's basically doing a hard shutdown. I'm using Ubuntu 18.04, although this used to happen with 17.10 too.

I've already tried this:

  • I've checked the settings on Gnome and it's set to Suspend
  • I've tried with GRUB_CMDLINE_LINUX="acpi_sleep=nonvs"

Also, I've noticed a few things:

  • I don't have a swap partition. I installed Ubuntu using the automatic partition tool.
  • /var/log/pm-suspend.log is empty

Any help would be much appreciated :)

  • 1
    I might have the same problem. In my case, resume doesn't work even in Windows, so I guess I have some HW-related troubles. BIOS seems to be setup alright in my case. Have you checked the BIOS settings? – Sebastian Apr 23 '18 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.