1

I'm running ubuntu 17 and I want to reconfigure my keyboard, thus I've made all the desirable changes inside my /etc/default/keyboard config and executed

$ source /etc/default/keyboard

but the changes didn't get applied.

I've also tried firing up

$ setxkbmap -model 105 -variant , -layout us,it -option "grp:caps_toggle, compose:ralt"

but to no effect...nothing I've tried seemed to get the newly made changes in the config apply. In the docs it says that I should use

udevadm trigger --subsystem-match=input --action=change

or reboot my system for the changes to apply, apparently I have no desire to reboot my system, I execute the command and nothing happens, that's, I still cannot change the layout using CAPS. I've simply run out of ideas... I know it is possible to configure it with something like

dpkg-reconfigure keyboard-configuration

etc but it's awfully inconvenient and terribly inefficient. After all what if I want to do a rather complicated configuration... What am I missing? How do I do such a nonsensically trivial thing as configure my keyboard? I used to run arch and debian and those distros were generous enough to give me the opportunity to change the damn thing without too much of a hassle...

EDIT

$ gsettings get org.gnome.desktop.input-sources sources yields the following list of tuples:

[('xkb', 'us'), ('xkb', 'it')]

The second command: $ gsettings get org.gnome.desktop.input-sources xkb-options yields the following list:

['grp:alt_shift_toggle', 'grp_led:scroll']

And apparently it's supposed to be grp:caps_toggle...why it's alt_shift_toggle I have no idea...

  • Are you running a desktop, and if so, which one exactly? Also, what's the problem with rebooting? It's the easiest way to change the keyboard configuration system wide. – Gunnar Hjalmarsson Apr 1 '18 at 16:11
  • @GunnarHjalmarsson Thanks for replying. Yes, it's gnome. The problem with rebooting is that as it's stated in the docs there's a more simple way of doing that. Does it mean I have to reboot my system every time I change anything like that?! I have a hell of a lot of apps open and a few important processes running....I don't want them to shut down. – Albert Apr 1 '18 at 16:19
  • @GunnarHjalmarsson Alright, I've just rebooted the system and as expected it didn't help. – Albert Apr 1 '18 at 16:25
  • Please run these two commands: 1. gsettings get org.gnome.desktop.input-sources sources 2. gsettings get org.gnome.desktop.input-sources xkb-options Then let us know what they output by editing your question. – Gunnar Hjalmarsson Apr 1 '18 at 16:33
  • @GunnarHjalmarsson I just did and posted the output in the EDIT. – Albert Apr 1 '18 at 16:44
0

Probably your user's settings override the system wide ditto as defined in /etc/default/keyboard.

The keyboard layouts seem to be fine. To define a compose key and change the shortcut for layout switching, it's easiest to install Tweak (the gnome-tweak-tool package) and do it from there. Such changes should be effective instantly.

| improve this answer | |
  • So you want to say there's some other config file that I don't know of ? Because no matter what I write in the /etc/default/keyboard it changes absolutely nothing. – Albert Apr 1 '18 at 17:12
  • @Albert: Yes. It's the ~/.config/dconf/user file. (But that's not a text file.) – Gunnar Hjalmarsson Apr 1 '18 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.