0

bash: source: /home/vj/.rvm/scripts/rvm: is a directory

Recently I tried to install ruby on my PC. And after that installation every time am starting my terminal it is showing the above message. I want to remove it because it's pretty annoying...I am new to Ubuntu so don't know much about it... So my only hope is you guys in the community

  • Check if that directory is mentioned in your .bashrc file in your home directory. – John Anderson Apr 1 '18 at 12:51
  • I reinstalled Ruby using rvm and that line has gone – Vishnu Jeejo Apr 2 '18 at 1:48
0

You have an equivalent of the following line in your ~/.bashrc file (taken from Ruby command not recognized after installing it with rvm):

source ~/.rvm/scripts/rvm

Delete or comment out that line. You can comment it out by placing a # in front of the line. The comment will allow you to fix it if you decide to continue with your Ruby installation/configuration at a later time.

It's that line that is running every time you start your terminal.

  • Another option is to test if the file exists before running it. ie something like if [[ -f ~/.rvm/scripts/rvm ]] ; then – WinEunuuchs2Unix Apr 1 '18 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.