0

I am trying to build ardour 5 on Ubuntu 17.10. When I try to configure it, it displays pkg -config => No How do I get pkg -config to work. I have searched all over but no answers because its not a common problem.

2

I built Ardour. You will need all the prerequisites (explained later). Python 2.6 should already be on your PC. Build it with:

    ./waf configure
    ./waf
    ./waf install

It will ask for some dependencies, so install those 1 by 1. LIST: sudo apt install libboost-all-dev gcc g++ pkg-config libasound2-dev libgtk2.0-dev glibmm-2.4-dev libsndfile1-dev libcurl4-nss-dev libarchive-dev liblo-dev libtag1-dev vamp-plugin-sdk librubberband-dev libfftw3-dev libaubio-dev libxml2-dev libjack-dev liblrdf-dev libsamplerate-dev lv2-dev libserd-dev libsord-dev libsratom-dev liblilv-dev libgtkmm-2.4-dev (ONE LINE)

| improve this answer | |
  • It is working now.. Thanks. <3 – Daniel Phil Mar 31 '18 at 19:55
  • I get this error still Checking for 'pangomm-1.4' >= 1.4 : not found The configuration failed – cyniphile Apr 9 '18 at 2:57
  • 1
    I had to change liblrdf-dev to liblrdf0-dev to make it work, other than that it worked great (at least with the waf configure, trying to build now...). Btw, I'm using the latest Ubuntu (bionic beaver) and Ardour's latest code from their git repo, as of today. – Adam Plocher May 14 '18 at 6:27
  • @cyniphile use sudo apt install libpangomm-1.4-dev – Tyler Lawrence Sep 8 '18 at 14:37
3

Update: Building Ardour 6 on Ubuntu 20.04

By trial and error, this might include some not needed packages:

This is from the previous answer, but with packages that errored removed:

sudo apt install -y libboost-all-dev gcc g++ pkg-config libasound2-dev libgtk2.0-dev  libsndfile1-dev libcurl4-nss-dev libarchive-dev liblo-dev libtag1-dev vamp-plugin-sdk librubberband-dev libfftw3-dev libaubio-dev libxml2-dev lv2-dev libserd-dev libsord-dev libsratom-dev liblilv-dev libgtkmm-2.4-dev

And this is all the packages installed in by terminal history (there might be some overlap):

sudo apt-get install -y \
libglibmm-2.4-dev libsndfile1-dev libarchive-dev liblo-dev libtag1-dev \
librubberband-dev libfftw3-dev libaubio-dev libxml2-dev liblrdf0-dev \
libusb-1.0-0-dev libcunit1-dev libwebsocketpp-dev \
libpangomm-1.4-dev libsamplerate0-dev lv2-dev libcunit1-dev libcppunit-dev \
libudev-dev libserd-0-0 libcwiid-dev libxwiimote-dev libserd-0-0 \
libserd-dev libwebsocketpp-dev libwebsockets-dev libsord-dev libsratom-0-0 \
libsratom-0-0 libsratom-dev liblilv-dev liblrdf0 liblrdf0-dev

Then do the normal:

./waf configure
./waf
./waf install
| improve this answer | |
  • am also on ubuntu 20.04. very helpful. Thanks! – ptetteh227 Jun 11 at 11:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.