4

I have ubuntu 16.04 installed.. whenever I boot the system and try to run ubuntu, busy box pops up. I do a manual check ---fsck -yf /dev/sda12--- and then reboot.. now the ubuntu boots properly but then after few minutes i am not able to save/write anything on ubuntu(says the the disk is read only) nor can i open my other partitions which i was able to access few minutes ago. I again restart my system and the same busybox appears. The cycle goes on and on. What should i do.. is my hard drive completely corrupted?

  • See my recent answer to askubuntu.com/questions/1019790/… and see if it applies to your situation. – heynnema Mar 31 '18 at 17:55
  • I have already done that.. also i did not install any windows driver – Mohit Kurani Apr 1 '18 at 10:54
  • What kind of primary disk do you use... hard disk or SSD? Open the Disks application and look at the SMART data to see if you're having a hardware problem. Do any of your other installed OS's have a problem also? – heynnema Apr 1 '18 at 12:31
  • A mistake from my side.. i did not run the command in recovery mode but in the normal mode... everything works perfectly now... thanks for the help, you are great :D – Mohit Kurani Apr 1 '18 at 15:20
3

Update #1: running fsck in recovery mode fixed the problem. I document this here to give the complete answer.

Lets first check your file system for errors.

To check the file system on your Ubuntu partition...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access
  • at the # prompt, type sudo fsck -f /
  • repeat the fsck command if there were errors
  • type reboot

If for some reason you can't do the above...

  • boot to a Ubuntu Live DVD/USB
  • start gparted and determine which /dev/sdaX is your Ubuntu EXT4 partition
  • quit gparted
  • open a terminal window
  • type sudo fsck -f /dev/sdaX # replacing X with the number you found earlier
  • repeat the fsck command if there were errors
  • type reboot
  • Thank you for share the solution it really helped me lots. Suddenly some directory was showing mount system/file system is read-only. I rebooted and it has fallen into initramfs – Ankur Loriya Dec 5 '18 at 7:41
  • This helped a lot after I shrank my root Ubuntu 18.04 partition – Juan C. Roldán Apr 20 '19 at 6:28
1

first, run the command

blkid

then check the number of partitions

it will look like

/dev/numve2: UUID="kksgasjhgdjh36876" TYPE="ext4" PARTUUID="bdmdmd7-iuuyuy-89jlh" /dev/numve4: UUID="kksgasjhgdjh36876" TYPE="ext4" PARTUUID="bjjlo-iuuyuy-89jlh"

now just run the command for all partitions:

fsck /dev/numve2 -y
fsck /dev/numve4 -y

after done for all partition just run :

reboot

and choose ubuntu it will work!!

  • this worked for my Ubuntu 18.04 – binpy Jun 16 '20 at 23:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.