I just changed to Ubuntu 11.10 and I have had a painful experience trying to configure the onboard VGA. I read a lot of articles here and in the web, looked everywhere, but I didn find a fix for it. Well, here goes my system specs:

  • Processor: AMD Phenom II 1090T Six cores
  • Memory: 4 GB of Ram
  • Graphics: Radeon HD 4290 onboard (512 MB shared)

For my surprise, the system is very laggy, the windows move slow when I grab and move them around, the scroll of Firefox is not fluid, I tried some games and emulators to test, open-msx run games but not fluid, ScummVM is the same story. When I open more than one window then it became more slow, Xara XL and Gimp get laggy after I do some work with them (the more filters I apply, the more slow the O.S. gets).

Well, I tried the driver that came with the install, the proprietary driver from additional drivers, the last version of Catalyst from AMD web site (the driver installs, but when I try to use Catalyst it says there iś no driver installed), I unmarked VSync in CCSM, and nothing changed. In my System Info tab, the graphics appears as VESA:RS880, I read there is some options for the driver: VESA, ATI, RADEON, RADEON HD as far as I can remember, VESA is more compatible but doesn't have acceleration and RADEON has good 2D and 3D acceleration for the system, so I tried to install a radeon driver but my system couldn't be accessed anymore, so I had to format again.

Sorry for the big text, but I spent some days trying to figure it out, I read a lot of stuff, I looked here, to see if there was someone with the same problem and VGA I have, but couldn't find anything. What am I doing wrong? Is there any other driver to make my VGA works better? Am I using the wrong Ubuntu version? I use Xara XL, Gimp, Inkscape and Blender a lot, so I am very worried about this and I know that my specs can give much more than I have now.

  • 1
    Did You try to login with Unity 2D instead 3D? Doesit help? – Misery Feb 7 '12 at 7:52

Have the same problems while using Ubuntu, except that i have another ATI videocard, 5770 HD. Install the latest ATI driver from AMD website, i prefer to create deb files and install drivers this way. I think this link is good for you: http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product= Manual installing tutorial on this page: https://help.ubuntu.com/community/BinaryDriverHowto/ATI

And then after drivers installed try to replace the Device block in your xorg.conf file with this one:

Section "Device"
 Identifier "ATI Radeon"
 Driver "ati"
 Option "AccelMethod" "EXA"
 Option "MigrationHeuristic" "greedy"
 Option "AccelDFS" "true"
 Option "EnablePageFlip" "true"
 Option "EnableDepthMoves" "true"

It's working for me and I have very smooth windows! Also save Sync to VBlank off and auto frame rate count in composite off too.

  • 1
    As victorhqc said, I installed 10.04 LTS and, after a lot of tests, everything was very fast, so, I read some more pages and found out I could enable Unity 2D and even install Gnome Shell, so I returned to 11.10 and installed it, I changed to Unity 2D and I could see a lot of improvement in performance, when I changed to Gnome Classic (without effects) everything was great, so I am using it now with the video driver from the instalation not the proprietary one. In my opinion it must be some issue with ATI driver and Unity 3D, I think my onboard VGA can´t handle it. Thnx for the help everyone! – Lord Avallon Feb 15 '12 at 17:51

Try using Ubuntu 10.04 perhaps a Long Term Support version will do, I've not tested it but you could try in another partition.

Have you used another version of Ubuntu? If so, the problem existed before?

Regards (:

  • Dear victorhqc, thanx for your reply! Well, I used Ubuntu through Wubi, I think it was version 7 or 8, it was some time ago, I had an NVIDIA 5700 LE VGA, and, as far as I remember it wasn´t very fast, I decided to migrate to Ubuntu because I thought my hardware upgrade could make it work better and I really prefer Ubuntu. Itś really painfull to not be able to use my hardware potential. Is this an issue with AMD VGAs? Anyway, I will try the version 10.04 and post the results. One more time, thanx! – Lord Avallon Feb 7 '12 at 14:25
  • Amd has some issues with performance in some cases, what I always recommend is to install the propietary drivers. Follow this instructions. askubuntu.com/questions/61520/best-driver-for-ati-radeon-hd4250/… – victorhqc Feb 8 '12 at 15:49

In Ubuntu you can find the appropriate additional required drivers.

  • Open Additional Drivers from System Settings.
  • Click Activate and them Authenticate it with your password.
  • Wait while it download and install the drivers.

If this does not solve your problem, then you have to try searching for any other solution.


Have you tried this http://www.psychocats.net/ubuntu/drivers .

  • 1
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Stefano Palazzo Feb 7 '12 at 10:13
  • 1
    @StefanoPalazzo thank you for your comment. I will not repeat this kind of laziness now on. :) Also, I've tried to improve my answer. Hope this would be good one. – user45315 Feb 7 '12 at 11:09
  • Dear Krishnan, thanx for your reply! Yes, I tried what you said, with no results, the proprietary driver is not very good, I tried the latest one in AMD´s website and it was the same thing. I´ve been searching all the net but couldn´t find a workaround or fix to this. Thanx for your help! – Lord Avallon Feb 7 '12 at 14:28
  • @LordAvallon I did read your comment in another answer saying you have installed Ubuntu through Wubi. Well, I would not recommend that. I prefer to use GParted (partition manager) to rip out some space from existing Windows Drive to make it as a new drive. And install Ubuntu in it. Also do not forget to reserve some space as a swap memory drive (virtual memory). – user45315 Feb 7 '12 at 14:39

Maybe a stupid question: are you sure your cpu settings in your bios are not set to single core? Had similar issues running HD videos with my radeon (catalyst driver) in unity untill I figured out that I had my 2nd core locked in my bios. Eversince I fixed that, everything seems to run just perfect! My system details always used to display the cpu name correctly, never knew it was supposed to say x2 at the end (x6 in your case). IMO unity 3d should work just fine with the catalyst driver but I could be wrong.

  • No, it´s not! It´s been a while, but I think it was some kind of problem with 11.10, because after I installed 12.04 LTS, it´s working very good. – Lord Avallon Jan 23 '13 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.