0

I tried doing this

Optional command for temporary root privileges. So you won't need to keep typing sudo.

$ sudo su

enter password. (Note. This is not required, you can continue to use sudo, if you choose.)

First step, make sure your current Ubuntu Version's installed packages are up to date.

$ sudo apt-get update && dist-upgrade

Y when prompted

After that finishes...

$ sudo apt-get install update-manager-core

Next up

$ sudo do-release-upgrade

But it brings me this error 'The package 'linux-headers-3.13.0-generic' needs to be reintalled, but it is impossible to find some appropriate archives'

marked as duplicate by Panther, mikewhatever, JoKeR, karel, DK Bose Mar 31 '18 at 14:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Yes, I have tried it and it bring me this error Invalid autoremove function – CaptainBunnyHood Apr 1 '18 at 11:19
0

Make your server system up-to-date

sudo apt-get update && sudo apt-get dist-upgrade

Reboot your system to finish installing updates:

sudo reboot

Install the update-manager-core package if it's not installed yet

sudo apt install update-manager-core

Edit this file, /etc/update-manager/release-upgrades using your favorite editor and set Prompt=lts:

vim /etc/update-manager/release-upgrades

update_manager

After this, start the upgrade process

sudo do-release-upgrade -d

You have to reboot one last time to finish

sudo init 6

Not the answer you're looking for? Browse other questions tagged or ask your own question.