0

A little while ago I started getting a black screen when resuming my computer from sleep. Suspension has been working fine for months but all of a sudden my computer gets completely unresponsive. I can't even switch to another tty. After a hard shutdown everything works fine, but the same behavior reappears after every suspend (systemctl suspend). It actually looks like the screen doesn't turn on at all. It's not just blank but completely black.

I've checked boot.log, syslog and the systemd logs and I can't find anything that looks like any serious problem.

My computer is a Thinkpad Carbon X1 (with an Intel graphics card) and runs the mini.iso release of Ubuntu 17.10. I tried updating my kernel to 4.15.0 but no change. I even tried reinstalling my entire system (including not using Luks-encryption for my home directory) still no change. Now I'm back to the standard kernel version (4.13.0)

I'm really stumped here an have no idea where to look right now. I'd really appreciate some help!

Thanks

0

I managed to solve my problem by removing nomodeset from the GRUB_CMD_LINE_LINUX_DEFAULT variable in /etc/default/grub and then running update-grub. I'm not sure why this change made any difference but apparently it doesn't work for me any more.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.