0

So I have follow other similar questions, but because they say switching to xorg solved it for them, I ask again.

I have nvidia drivers because I need them for work they are the latest ones 384.111.

Im on xorg because I disabled WaylandEnable=false and have also used gnome-shell -r but without real effect, now for use Ubuntu I need to first start opening all the applications I need, or open them from terminal.

Hiting the windows key doesnt show anything, nor alt+f1 or alt+f2 also sometimes the windows mouse clicks on things on other virtual desktop (like instead of sending the commands to the current app to the previous one or sometimes to the window that is below!!!), also I need to press alt+space to resize or move a window.

How something basic as mouse and keyboard got crashed? and how to solve it without reinstall? (I mean I have already put a lot of effort configuring and downloading things).

What commands can I show you to take a best diagnostic of this?? because "I can use ubuntu" but it is almost unusable right now.

I cant click on:

  • gitg
  • top right korner for shutdown, so I need to power down the box to shut it down, or write shutdown now in a terminal.
0

I tried localectl set-x11-keymap us to set my keyboard layout as US keyboard. I ran given command in tty1 console because my Xorg wasn't launching successfully.

Related man pages:

man localectl
man 7 xkeyboard-config
man setxkbmap

I am running Arch and that is why I was looking for Arch wiki. localectl must be available in Ubuntu.

I got help from this page.

1
  • This is my first entry on StackOverflow / AskUbuntu. I don't know about markdowns. Sorry for not being able to highlight commands and links like other entries. I hope my answer helps your problem. – MrtzYsl Jun 7 '18 at 3:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.