3

I'm trying to install the nvidia drivers via:

sudo apt purge nvidia-*
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get install nvidia-390

They seem to install (though I don't actually know for sure if I'm running on my Nvidia graphics card or my Intel card).

I expect to be able to run nvidia-smi to take a look at the Nvidia GPU (nvidia-smi is a very funamental monitoring tool included with the nvidia drivers).

$ nvidia-smi
nvidia-smi: command not found

But I just get a command not found after this installation.

How do I install nvidia-smi using this ppa? Am I not understanding something? Are these PPAs incomplete? I'm trying to configure this for tensorflow, so CUDA & CuDNN libraries are up next. But I can't deal with that until I can at least validate that the GPU drivers are properly installed, and the only way I know to do that is via nvidia-smi. On the nvidia forums I'm told that this tool normally installs with the driver and they suggest not using the PPA (but their supported installation process is even more painful).

  • Why not use Launchpad email & ask the ppa's admin why they don't provide nvidia-smi? (they do now for 18.04 but in 18.04 the repo package is probably better at this point.. – doug Mar 30 '18 at 21:18
  • What is this launchpad email you refer to? – David Parks Mar 30 '18 at 21:20
  • 1
    When you go to the ppa page right above the Overview of published packages you'll see a For questions and bugs with software in this PPA please contact link. click on it > on the resulting page look to far right, you'll see a contact this teams admins link. That'll open up an email dialog. Note that you likely needed to be logged into launchpad to use. If that is onerous to you, (setting up a LP account), post back, i'll ask for you.. – doug Mar 30 '18 at 23:49
  • Otherwise it may be possible to use ubuntu-bug to file a bug. Most ppa packages can't use ubuntu-bug but maybe that ppa has a hook. If so tag the bug Proprietary GPU Drivers ppa or something. ( the ppa page doesn't mention so maybe not .. – doug Mar 30 '18 at 23:54
  • 1
    Hi David, please execute sudo lspci -k | grep -EA2 'VGA|3D'. If the output includes the message Kernel driver in use: nvidia - then the NVIDIA drivers are properly installed. :) – cl-netbox Apr 3 '18 at 8:40
2
+50

I had almost the same issue with nvcc. Fixed this way:

sudo apt install libcuda1-390 nvidia-opencl-icd-390

Since these packages have been kept back

  • These references were useful, thanks. Though for posterities sake, nvidia-smi actually is installed with nvidia-390 my actual problem stemmed from them not getting loaded correctly and paths not being set up properly. nvidia-smi resides, by default, in /usr/lib/nvidia-390/bin/nvidia-smi – David Parks Apr 8 '18 at 16:49
  • @DavidParks, so how did you solve this problem?. Did you add the directory to path? I have the same kind of problem. Please help. – Joshua Owoyemi Sep 20 '18 at 20:33
  • I gave up and reinstalled the whole bloody OS. I tried everything, posted everywhere for a month, I must have dumped 40+ hours into the problem. I've written off dual graphics cards and nvidia installations as a lost cause on linux. Keep it as simple as possible, don't get fancy, and you might just get something that resembles a working environment. Dual graphics cards and better virtual memory management are my two biggest wish-they-worked-like-windows wishlist items. – David Parks Sep 21 '18 at 22:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.